Home Forums Bug Reports New field not saving data


New field not saving data

  • I have added a new field to an existing field-group->flexible content->layout. When i put some content in the new field and save the post, the new field’s content is not saved.
    When i rename an existing field and put some content inside it is saving perfectly. The Problem only occurs with newly created fields.

    I also use WPML-Plugin and when i create a new field in the second language, everything is working fine.

    I tried to disable all Plugins(including WPML) except ACF and i used a standard WP-theme, but that did not help at all.

    Does anyone have similar problems or a solution?

    WP-Version: 5.1.1
    ACF-Version: 5.7.13 (PRO)
    WPML-Version: 4.2.5

    max_input_vars are set from 1000 to 3000 but it did not solve the problem.

  • I had the same problem. I started this thread only a few days before yours.

    I was actually able to get this working by duplicating the Field Group and deleting the old one. Since the fields had the same names, they were still populated with all of the old data.

  • That really solved it. Thank you very much.

    If anyone else will try this please backup your database und export your fields. Just to be safe if something goes wrong.

  • @bronson That solved it for me too. Thank you! This happened to me using the most recent version of ACF in 2021. Don’t know what causes this weird hiccup.

    In case this helps someone else: it was happening to me only on certain field groups inside a flexible content field group. But you have to duplicate the whole flex content group and delete the old one. It won’t work if you just delete the fields inside the flex content field.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.