Support

Account

Home Forums Backend Issues (wp-admin) Fields not showing since recent update

Solving

Fields not showing since recent update

  • Hi, we recently updated our clients website to WordPress version 5.2 and ACF version 5.8.0 and for some reason a custom field group is no longer showing on our home page in the back end.

    The website is: https://www.tbftraffic.com/

    It still outputs the fields that have data entered into them from before it stopped working, but you can’t see the fields on the back end any more.

    We have a custom template for the home page and then a field group that is set to show on all pages that use the template.

    Custom field groups are working fine elsewhere with the same logic (only show fields on pages that use the “landing page” template), but the home page one seems to have stopped.

    It has worked fine for over a year, until the update.

    Anyone know what the issue could be?

  • Having the same issue here. Got a repeater for an image slider that now suddenly doesn’t appear in the backend, but still delivers the data that was present before the upgrade on the frontend.

    Won’t appear if it is set to show on Front Page or set to show on the specific page template. Weirdly one of the other repeaters setup on the same page is working fine.. Very odd!

  • Got the same issue, too.
    We’re using a bunch of custom shortcodes added to WPBakery. Somehow the Backend-Editor doesn’t render the shortcodes properly – Frontend-wise they still work.

  • haven’t got a clue what’s up with WPBakery. for the others, if you’re using the block editor then it’s probably something to do with that and you should contact support here https://www.advancedcustomfields.com/contact/

    • CCAZ

    • June 5, 2019 at 2:47 pm

    I am experiencing same issue as OP. This broke sometime after 5.0.4. Have any of you resolved this issue?

    I just upgraded from WP 4.8, plugin broke, and now I’ve been slowing upgrading to find where it breaks.

  • I’ve contacted support, will update this thread if a solution is reached 🙂

    • CCAZ

    • June 5, 2019 at 2:55 pm

    Thanks! For the time being I’ve rolled WP back to 5.0.4.

  • Contacted them too 🙂

    • CCAZ

    • June 5, 2019 at 5:23 pm

    @bartyfilm I found a partial solution. I think that ACF is not recognizing custom types of posts/pages ( I’m not sure what correct terms are ) .

    We use a type of post called Project.

    I toggled it to affect normal posts instead of Project. Viewed the “Post” and it was working. Then toggled it back to Project – and the custom fields are showing up now on the backend.

    Do you have custom post/template types?

    background:

    I originally rolled from 5.2.1 to 5.0 – and still experienced the problem. So I have been upgrading slowing, starting with it being stable on 4.8. I was surprised to find that this time, when I got to 5.0 it appeared to be working. At least, it was working on _Existing_ pages, I forgot to check creation of new items. My first thought was that it was necessary to do a major upgrade at a time ( 4.8 -4.9->5.0->5.1 )

    When I got to 5.1, I found existing pages were still working (!), and was excited my plan worked. However new pages, did not – they lacked the necessary custom forms.

    I went into ACF, and everything looked ok. So I tried assigning those fields to another type of post and it worked. When I toggled them back to “projects” now it works.

    I found this interesting – when I loaded up a project to review I saw this:

    There is an autosave of this post that is more recent than the version below.View the autosave

    When I compare the two I see that the “newer” version ( a draft that was saved during the upgrades ) lacks the custom fields.

    So my best guess is that ACF is not honoring the existing rules, and they need to be re-saved for them to “stick”.

    I’m running on 5.2 right now, and that’s good enough for the short term. I’ll mess with it more after the conference I’m supposed to be prepping for 🙂

    Have you found the most recent version of WP that yours works on correctly?

    • CCAZ

    • June 5, 2019 at 5:28 pm

    What the heck. I just wrote a long post with a possible solution, and I’m not seeing it here.

  • Weird – got it in another Tab. Shall i copy-paste?

    • CCAZ

    • June 5, 2019 at 5:34 pm

    Sure! If that fails, here is the short version for other peeps:

    TLDR: go into ACF, assign your fields to POSTS or other non-custom page. Save. Confirm they are working. Then go back and reassign those rules where you want them. See if this fixes it. It’s working for me on wp 5.2.

  • @ccaz wrote:

    @bartyfilm I found a partial solution. I think that ACF is not recognizing custom types of posts/pages ( I’m not sure what correct terms are ) .

    We use a type of post called Project.

    When I toggled it to affect another group. saved. viewed. then toggled it back to Project – it appears to work now.

    Do you have custom post/template types?

    background:

    I originally rolled from 5.2.1 to 5.0 – and still experienced the problem. So I have been upgrading slowing, starting with it being stable on 4.8. I was surprised to find that this time, when I got to 5.0 it appeared to be working. At least, it was working on _Existing_ pages, I forgot to check creation of new items. My first thought was that it was necessary to do a major upgrade at a time ( 4.8 -4.9->5.0->5.1 )

    When I got to 5.1, I found existing pages were still working (!), and was excited my plan worked. However new pages, did not – they lacked the necessary custom forms.

    I went into ACF, and everything looked ok. So I tried assigning those fields to another type of post and it worked. When I toggled them back to “projects” now it works.

    I found this interesting – when I loaded up a project to review I saw this:

    There is an autosave of this post that is more recent than the version below.View the autosave

    When I compare the two I see that the “newer” version ( a draft that was saved during the upgrades ) lacks the custom fields.

    So my best guess is that ACF is not honoring the existing rules, and they need to be reassigned.

    I’m running on 5.2 right now, and that’s good enough for the short term. I’ll mess with it more after the conference I’m supposed to be prepping for 🙂

    Have you found the most recent version of WP that yours works on correctly?

  • That’s strange, I was reading you post but then it was gone! In any case I tried what you suggested and did not have any luck. I have a custom page set as Front Page.

  • Weird.. Posted it too, modified once – still there, modified again to highlight code – gone…

  • @ccaz wrote:

    @bartyfilm I found a partial solution. I think that ACF is not recognizing custom types of posts/pages ( I’m not sure what correct terms are ) .

    We use a type of post called Project.

    When I toggled it to affect another group. saved. viewed. then toggled it back to Project – it appears to work now.

    Do you have custom post/template types?

    background:

    I originally rolled from 5.2.1 to 5.0 – and still experienced the problem. So I have been upgrading slowing, starting with it being stable on 4.8. I was surprised to find that this time, when I got to 5.0 it appeared to be working. At least, it was working on _Existing_ pages, I forgot to check creation of new items. My first thought was that it was necessary to do a major upgrade at a time ( 4.8 -4.9->5.0->5.1 )

    When I got to 5.1, I found existing pages were still working (!), and was excited my plan worked. However new pages, did not – they lacked the necessary custom forms.

    I went into ACF, and everything looked ok. So I tried assigning those fields to another type of post and it worked. When I toggled them back to “projects” now it works.

    I found this interesting – when I loaded up a project to review I saw this:

    There is an autosave of this post that is more recent than the version below.View the autosave

    When I compare the two I see that the “newer” version ( a draft that was saved during the upgrades ) lacks the custom fields.

    So my best guess is that ACF is not honoring the existing rules, and they need to be reassigned.

    I’m running on 5.2 right now, and that’s good enough for the short term. I’ll mess with it more after the conference I’m supposed to be prepping for 🙂

    Have you found the most recent version of WP that yours works on correctly?

    • CCAZ

    • June 5, 2019 at 5:42 pm

    huh, maybe the embedded images are requiring moderation or something. Thanks for trying!

    @bartyfilm do you have a plugin for rolling back the core install? I’m using WP Downgrade | Specific Core Version

    I’m assuming you have backups using updraft or something. If not, definitely get those now.

    Try rolling back to 4.9.10, see if it works there. If so, try upgrading to 5.0. What was the last version it was stable for you on?

    Here is a list of versions you can upgrade through until it breaks:
    https://wordpress.org/download/releases/

  • ccaz post

    • CCAZ

    • June 5, 2019 at 5:44 pm

    heh

  • ha! gotcha 😛

    • CCAZ

    • June 5, 2019 at 5:46 pm

    nice!

  • Hi all,
    Kenny from ACF support was able to sort this out for me quite easily, here is his response;

    I suspect that the issue affects your current user because you had “reordered” metaboxes on the edit screen.

    The “fix” we added on the latest version, changes all “high” metaboxes to “normal”. This allows metaboxes to appear correctly in Gutenberg, but is most likely conflicting with your users “reorder” setting.

    To change and fix this from your end, please edit the wp_usermeta table and delete the rows containing “meta-box-order_…”. This will allow all metaboxes to appear as expected.

    Basically I just removed all the “meta-box-order_*” entries from the wp_usermeta table in the database and now I can see everything as normal again.

    Hope this helps and again big thanks to Kenny 🙂

    • esaner

    • June 8, 2019 at 9:34 am

    Thanks for posting this fix!

    • lundweb

    • June 14, 2019 at 10:12 am

    Thank you, thank you, thank you for posting the resolution! Saved the day, I was about to start re-entering all the data since duplicates of the original groups worked. Thanks to this the problem is easily resolved!

  • Quick update from my side:
    Stumbled across a WPBakery-Bug that’s going to be fixed within next update coming next week.

Viewing 25 posts - 1 through 25 (of 36 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.