Support

Account

Home Forums Backend Issues (wp-admin) Fields not showing since recent update

Solving

Fields not showing since recent update

  • @bartyfilm thanks for that, that fixed it for me as well.
    You can run this on the db to fix: DELETE FROM wp_usermeta WHERE meta_key LIKE "meta-box-order_%";

    • jg314

    • June 21, 2019 at 8:54 am

    Thanks to everyone who posted here so we could narrow down the issue. While modifying the database directly does fix the problem, that presents a significant amount of risk and also would be incredibly time consuming if you’re managing a lot of websites.

    Does anyone know if the ACF team is working on rolling out an official fix for this?

    • jg314

    • July 16, 2019 at 5:51 am

    As a heads up for anyone having this issue, it’s been fixed in version 5.8.2.

    • CCAZ

    • July 16, 2019 at 10:22 pm

    is 8.5.2 live?

    • jg314

    • July 16, 2019 at 10:41 pm

    8.5.2 is live for ACF PRO, but it looks like the fix hasn’t been released for the free version yet.

  • I still have problems with 8.5.2 PRO. The only way I have ‘solved’ the issue is to duplicate the field and delete the original. This does mean the content disappears.

    It’s a strange as the problem only exists on our staging/live server and not local dev machines.

  • Not sure this will help anyone else, but after trying nearly all of the fixes I found in this forum and elsewhere (none worked), I was able to come up with one that worked in my situation.

    I, too, was not seeing any content populated in the page editor ACF fields as location-related to two templates I had on various sites. And no data was being saved if I tried to enter it into the ACF page editor fields.

    While troubleshooting, I noticed in reviewing the ACF field settings in Custom Fields>Field Groups>(item)Field Name, I was getting <p></p> tags within the field every time I saved the ACF Field Groups settings even though I deleted the tags prior to saving.

    Remembering that the TinyMCE Advanced plugin has an option for keeping paragraph tags within the text editor, I tried disabling TinyMCE to see if it would get rid of the paragraph tags. It didn’t, but I had forgotten that I also had the TinyMCE Excerpt plugin installed. So I disabled that and VOILA! The paragraph tags disappeared after saving the field settings again, and my ACF metaboxes were populated and editable again in the page editor.

    So even if this was also the case for you, disabling all of your plugins (including TinyMCE), would not have produced any successful outcomes unless you then went into your Field Groups settings and updated all of the Field Names to remove extraneous tags.

    I spent an entire day trying to fix this. If it helps one person, it will be worth posting it here.

  • Not sure this will help anyone else, but after trying nearly all of the fixes I found in this forum and elsewhere (none worked), I was able to come up with one that worked in my situation.

    I, too, was not seeing any content populated in the page editor ACF fields as location-related to two templates I had on various sites. And no data was being saved if I tried to enter it into the ACF page editor fields.

    While troubleshooting, I noticed in reviewing the ACF field settings in Custom Fields>Field Groups>(item)Field Name, I was getting <p></p> tags within the field every time I saved the ACF Field Groups settings even though I deleted the tags prior to saving.

    Remembering that the TinyMCE Advanced plugin has an option for keeping paragraph tags within the text editor, I tried disabling TinyMCE to see if it would get rid of the paragraph tags. It didn’t, but I had forgotten that I also had the TinyMCE Excerpt plugin installed. So I disabled that and VOILA! The paragraph tags disappeared after saving the field settings again, and my ACF metaboxes were populated and editable again in the page editor.

    So even if this was also the case for you, disabling all of your plugins (including TinyMCE), would not have produced any successful outcomes unless you then went into your Field Groups settings and updated all of the Field Names to remove extraneous tags.

    I spent an entire day trying to fix this. If it helps one person, it will be worth posting it here. Good luck!

  • Reposting:

    Not sure this will help anyone else, but after trying nearly all of the fixes I found in this forum and elsewhere (none worked), I was able to come up with one that worked in my situation.

    I, too, was not seeing any content populated in the page editor ACF fields as location-related to two templates I had on various sites. And no data was being saved if I tried to enter it into the ACF page editor fields.

    While troubleshooting, I noticed in reviewing the ACF field settings in Custom Fields>Field Groups>(item)Field Name, I was getting <p></p> tags within the field every time I saved the ACF Field Groups settings even though I deleted the tags prior to saving.

    Remembering that the TinyMCE Advanced plugin has an option for keeping paragraph tags within the text editor, I tried disabling TinyMCE to see if it would get rid of the paragraph tags. It didn’t, but I had forgotten that I also had the TinyMCE Excerpt plugin installed. So I disabled that and VOILA! The paragraph tags disappeared after saving the field settings again, and my ACF metaboxes were populated and editable again in the page editor.

    So even if this was also the case for you, disabling all of your plugins (including TinyMCE), would not have produced any successful outcomes unless you then went into your Field Groups settings and updated all of the Field Names to remove extraneous tags.

    I spent an entire day trying to fix this. If it helps one person, it will be worth posting it here.

    • CCAZ

    • August 9, 2019 at 1:45 am

    I’m seeing your post! Supposedly this was fixed in the latest version – have you tried updating?

  • I did have the latest version installed, both WP core and ACF. I understand that my situation might be a bit unique with the conflicting plugin, but thought I would share nonetheless. 🙂

Viewing 11 posts - 26 through 36 (of 36 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.