Home Forums Backend Issues (wp-admin) Field Disappears on Edit screen


Field Disappears on Edit screen

  • Hi,

    All my fields disappeared on the Edit Field Group page.
    (Similar problem to here

    Location and Settings sections are still visible. When I navigate to Screen Options and deselect and then re-select the Fields option, this doesn’t solve the problem.

    I can see that the divs are there in the HTML inspector and they’re set to ‘display:none’ for some reason.

    Any advice for how I could resolve this?
    I’m currently running on a local server as I’m developing.


  • I had this issue once, but do not remember what I did to fix it.

    This is based on my muddled memory of the incident and may not help. Has this field group been trashed and then restored? It is was look at the field keys of the field and see if they have “trashed” in them anywhere.

  • Hi @hube2,
    I haven’t no, it’s happening to all Field Groups that I have. I’ve only ever trashed one Field Group and that’s been permanently deleted. All the data is still working on the site and is evidently there in my JSON folder (acf-json) too.

    It feels like some strange style override in the admin hiding the fields for some reason?
    I’m hoping someone can help resolve the bug.

  • This is what I would do, please note that I haven’t got a clue if this will help and note step one about backing up the DB just in case something goes wrong.

    1. Backup the DB
    2. Download all of the JSON field groups
    3. Trash and Delete one of the field groups that is having an issue (all of the data will remain in the DB)
    4. Using the files you downloaded, import the group you just deleted
    5. See if this corrects the issue with that group
    6. If it does, rinse and repeat with the remaining groups.
  • Hi John,

    Unfortunately that didn’t solve the issue either.
    It’s as if ACF is stuck in a state that is styling that meta box to display:none.

    I was sent this link where someone else had the same issue.
    They give a good explanation to why they thought it happened, but sadly their fix didn’t work either. But I thought I’d include it here for others in case they run into the same problem.

    It’s very strange.


  • I’ve managed to fix the issue by.. turning it off and on again!

    Simply by deleting the plugin and installing it again solved the issue.
    I should have tried that to begin with really.

    Interesting though is that the design/layout of ACF has updated for me so maybe there was an issue when I last updated it? Because my version was up to date.

    Anyway thanks @hube2 for taking the time to try and help.

  • It is possible for files to get corrupted during the update process, this goes for any update, which is why I will never have my clients’ sites update automatically and I think doing so is foolish unless you like being called in the middle of the night by a client because their site has crashed.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.