Support

Account

Home Forums Backend Issues (wp-admin) Can't add more fields!

Solved

Can't add more fields!

  • I am unable to add more fields to groups that already have a large number of fields
    .
    I am able to add the field information, but I can’t save it. I found another post here about the same topic – and the solution was to up update php settings to allow more memory. My server (VPS) already allows me to run 128MB of memory. But I still can’t add more fields.

    I get no errors whatsoever. My WP debug is on. I have no PHP memory limit exceeded errors as one usually gets when running into this issue.

    Also, once I click on the update button, the page does reload, and tells me that the group has been updated – but it hasn’t.

    Any ideas on how to solve this issue?

  • Hi @daniel@push10.com

    Can you please read the server error log. There will most likely be an explanation for the abrupt termination of the save_post action.

    Cheers
    E

  • Elliot,
    I could not find any specific error related to ACF. I did find other errors, and so I took care of them, and so far ACF is back to normal. Thanks for your help.

  • Same error here. Just updated from 4.2 to 4.2.2 but the error still exist. I can create new fields, but can’t update existing ones. I get a “xxx updated.” message, but the field doesn’t get updated.

    The server logs don’t show any errors.

    Also updated WP from 3.6 to 3.6.1 – no success.

    Debug mode is active, too. Nothing.

  • Hi @krad

    Thanks for the info. I’m not sure what is going wrong here. If there are no errors, then perhaps they are being hidden by a server setting?

    Are you able to contact your server and ask them what the issue could be?

    Also, If you are able to, you can debug the issue in code. Jump into the core/controllers/field-group.php file and find the save_post function.

    I would look at the loop which loops through the fields, and just echo out the name of each field. Then use a die at the end of the loop.

    Now when you save your field group, what field name does it get up to?
    That will give you some data to go from.

    Thanks
    E

  • Same problem here. Today I see that a few fields of a large field group disapeared in the back end. I don’t know after what update this comes, but now I can re-add and after saving there gone again. ๐Ÿ™

    But sometimes – I don’t know when – some fields appeared again and after next saving they are gone again …

    Then use a die at the end of the loop.

    Can you specify what I must do?

  • Hi @svenni

    It sounds like you are sitting on the cusp of your PHP limit. This would explain why sometimes the sub fields are loaded, and other times it is not.

    Hitting your PHP limit will cause the current function to just stop, so when ACF is loading in the fields, it is most likely running out of memory and just stopping.

    Have you contacted your host to look at error logs?

    The die I mentioned was in regards to debugging the save_post function in the core/controllers/field-group.php file.

    My advise was to edit the loop which saves the fields, and simple echo the field name, then die at the end of the loop. This will visually show you how far the loop got through.

    Does that help?

  • Hi elliot,

    I don’t know what you excactly mean, but the workaround in the other high topic to this problem

    http://support.advancedcustomfields.com/forums/topic/max_input_vars-solution-not-working-for-me/

    with the user.ini fixed it. But I don’t think that this should be a solution for ever …?

    But I think about a way we don’t depend on such big field groups:

    Is there a chance that you can implent conditional (tab and/or hide) logic over field groups? Than we can split big field groups and can use tabs and/or hide fields furthermore.

    Or add a new field typ “field group” so we can include a field group in a field group.

    Edit: Another user had the idea a month ago:

    http://support.advancedcustomfields.com/forums/topic/reusable-field-groups/

    Greetings,
    Svenni

  • I ran into this same issue again. This time no log errors. It seems that once I have too many fields I run into saving issues. Currently, all fields save, but the Rules conditions are not. So weird.

  • I think i solved the problem by increasing PHP limit. You have to add to your .htaccess file this piece of code and everything will run smooth:

    <IfModule mod_php5.c>
    php_value suhosin.simulation 1
    php_value suhosin.post.max_vars 6000
    php_value suhosin.get.max_vars 6000
    php_value suhosin.request.max_vars 6000
    </IfModule>

    ๐Ÿ™‚

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Can't add more fields!’ is closed to new replies.