Support

Account

Home Forums ACF PRO "Automatic update is unavailable for this plugin"

Solved

"Automatic update is unavailable for this plugin"

    • Peter

    • July 25, 2018 at 6:37 pm

    I’m experiencing 3 sites on 5.7.0 that, despite re-entering the licence key (twice for each), just say “Automatic update is unavailable for this plugin”.

    I have had this problem with updating before on various sites (not necessarily the same 3), but re-entering the key solved it. Not now though.

  • Same error here with 5+ different pages. But on other pages the update works…?!

    • thartl

    • July 26, 2018 at 11:33 am

    Same here on a few sites.

  • Same here but not on all sites, just one. Disabling all other plugins didn’t help.

  • somehow it’s working on more and more sites. strange…

  • Same problem here! Updates worked on the first few sites I was running maintenance on, but just came across it on a new site that was missing a license key initially.

    After activating the license key it was still preventing me from updating.

    :/

  • Same here. Tried deactivating license and re-entering it, to no avail.

  • After a few days, I checked the site again, and it has seemed to corrected itself. No idea why, but now I am able to update! Yay!

  • It could just be that the update server was unreachable or having a problem at the time. It happens occasionally. If it persists I would contact support https://www.advancedcustomfields.com/contact/.

  • I’ve been having the same problem lately on my local development sites. This has been going on for a couple months.

    I am unable to update on .test domains even though I see them in my “Manage Activations”. It even shows a sensible “Modified” datetime, ie: 2018-08-18 18:24:34.

    I am able to update my live versions, ie.: domain.com

    But whenever I try and update my local version, ie.: domain.test; I am getting the “Automatic update is unavailable for this plugin.”

    I’m even updating the License Key locally and I am still unable to update.

  • Same happened to me,
    the site activation is for has to be the site of instalation (at least for first activation).
    My solution was: uninstall & remove plugin, reinstall and activate again – suddenly, updates were available.

    • Peter

    • August 21, 2018 at 8:44 pm

    Looks like this has reared it’s ugly head again. The update to 5.7.3 isn’t available on 5 sites now. Interestingly, 3 of them are on the same server (literally the same – installed in sub-directories) and yet a 4th one has updated, so it’s not as if the server is blocking the connection!

  • Same here. The latest update (5.7.3) is NOT available. I’ve entered my Pro key to no avail.

  • I’m seeing the same thing with 5.7.3 on recently licensed (last few days) sites. Sites that were licensed at least a couple weeks ago unaffected.

  • I’m having the same problem too. 5.7.2 won’t update to 5.7.3 on staging site even after re-entering license.

  • 5.7.4 available but returning “bad request”

  • I’ve been encountering this quite a bit the last couple of weeks as well.

    The latest site was running 5.7.3 and was showing “Automatic update is unavailable for this plugin” on the Plugins page. I went to Dashboard -> Updates and tried running the update there, which failed saying the package was not available. I refreshed the Updates page using the “Check Again” button, then went back to the main Plugins page and the notice was gone. I was able to successfully update at that point.

    Will have to give it a try on the various other sites I’m working on to see if that works consistently.

    • Peter

    • September 10, 2018 at 8:49 pm

    Hi kmeronuk – thanks for the suggestion. I can confirm that clicking the “Check Again” button on the main WP updates page (eg http://www.example.com/geneve/wp-admin/update-core.php) solves the problem on two of my sites for me too.

    However, I clicked on the “solved” button on your reply too soon, as there are still 2 other sites still with the same old problem, so still not 100% solved!

    :-/

    • Peter

    • September 10, 2018 at 8:56 pm

    Having said that, deactivating the licence, clicking the “Check Again” button, re-activating the licence, clicking the “Check Again” button again and going to plugins has finally solved the problem!

    I’m guessing there must be some internal WP cache that ACFpro is having problems with.

  • I had this trouble recently on a dev site, on friday afternoon. I changed the domain name of the site, then I re-entered my license which you need to do whenever you change domain names, and I got the “updates unavailable” message. This morning the same site is working fine. I have to assume there is some type of caching issue somewhere.

  • Getting same error as everyone else. Can’t update ACF Pro on some sites, while others work using the exact same auth code.

    An error occurred while updating Advanced Custom Fields PRO: Before you can receive product updates, you must first authenticate your Elegant Themes subscription. To do this, you need to enter both your Elegant Themes Username and your Elegant Themes API Key into the Updates Tab in your theme and plugin settings. To locate your API Key, log in to your Elegant Themes account and navigate to the Account > API Key page. Learn more here. If you still get this message, please make sure that your Username and API Key have been entered correctly

    All sites are on the same server. Tried many of the techniques in this thread.

  • OK, as soon as I posted, I got it to work! Go to Updates -> click Check, then go to Plugins page and it should be update-able… Or something else was going on and this worked by coincidence.

  • There is something in the database that is causing the issue, unfortunately, I don’t have any more information at this time. I tried what was suggested by support, that is deactivate and reactivate the license. This did not work.

    Since I was working with a dev site and I could I dumped the database and reinstalled WP, this corrected the problem on this site. I realize that not everyone can do this, but it did confirm that it is something in the DB, perhaps some old transient that is not getting updated properly. If I have the problem on another site I will investigate further.

  • Latest suggestion from support if anyone wants to try it

    – Deactivate the license
    – Delete the _transient_acf_plugin_updates from the wp_options table
    – Reactivate the license
    – From the Update Plugins page (not the Plugins page), select ACF PRO and hit update.

  • @john Huebner:

    Your last suggestions don’t work for me unfortunately. I have been unable to update ACF Pro for about 3 weeks now on 2 separate multisite installations, they always produce a ‘bad request’. I have removed the update transients in both the multite sitemeta table and the options table of the primary blog to no avail.

Viewing 25 posts - 1 through 25 (of 42 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.