Support

Account

Home Forums ACF PRO ACF not playing nice with WPML

Solved

ACF not playing nice with WPML

  • I am using ACF Pro 5.0.7 with WPML 3.1.7.2.
    I have set up WPML in 2 languages – English/ French.
    I have created various ACF field groups and they all work perfectly on the main language and are included in the translated pages.

    I can add any content/ new ACF blocks etc to the main language and to the translated pages but cannot save anything on the translated pages.
    All the field groups, content everything is removed giving me just a blank page.

    Any ideas?

    TIA.

  • Thanks guys, I’ll do some testing

  • Just as an update – I’ve rolled back to 4.3.8 and done a few quick tests and elements seem to be working fine.

    I’ve also noticed that I cannot use the page link option – spinning but not finding any pages/ posts – they have been selected correctly in the CF settings etc.

    I’m putting it down to a script conflict somewhere between ACF and WPML.

  • Same here. Using the Pro version ACF 5.0.7 with WP 4.0 and WPML 3.1.7.2

    I have to desactivate WPML and re-enable it after to be able to save custom field inside a page or article.

  • As another update – I’ve also been getting similar problems using ACF Pro/ WP 4.0 without WPML as well, so a straight forward install with no other plugins etc.

    This time the issue is with the page link/ post object dropdowns not being able to select anything.

    Again, rolling back fixes this issue.

  • Sorry for the bump, but any updates on this?

  • Hi,

    We just had the exact same issue with ACF 5.0.8 and WPML 3.1.7

    We just resolved it by changing WPML options :
    WPML > Translation Management > Multiligual Content Setup > Custom posts

    We had to check
    – “Translate” for “Fields Group” and
    – “Do nothing” for “Fields”

    Everything seems to works fine know but we’re still checking.
    Hope it helps.

    Bye

  • Once again WPML and ACF don’t work well together. Some days they do, other days they don’t. There’s no easy way to set these two plugins up well.

    WPML 3.1.7.2 and ACF Pro 5.0.8

    Jeremie’s settings don’t work in my site.

  • Hi guys

    I can’t replicate any of these WPML issues. Can you please clearly explain what is going wrong + steps to reproduce the issue.

    Thanks
    E

  • This reply has been marked as private.
  • Hi @studiowizjo

    You are the man! Thanks mate, I’ll do some testing and get back to you soon

  • Hi.

    Is there any ongoing development to solve this issue?
    I just want to say hi – and hope to speed this up.

    Am thinking of that the problems with the combination of acf and wpml really is a huge advantage since both of these plugins makes WordPress so powerful.

    My concern is the “Settings of Multilingual content” that comes with WPML. But since Elliot is the true magician – I hope he/you can solve this.

    But I also has these problems, that translated pages is having a hard time “copying content” from repeaters, as well as adding new blocks in other languages.

    I know WPML and ACF does not really add up to a great combination in every moment, but I wish to make it a little more streamlined.

  • Hi @studiowizjo

    The url does not exist anymore. Can you please post a correct login?

  • Hi guys,

    I am still unable to produce any of the WPML issues. Can I ask for a very clear description of the issue with a set of instructions to reproduce the exact issue?

    Also, some login details would be great to see this in action.

    Thanks
    E

  • Sorry, now it works again.

  • I was helped out by this comment:

    “We had to check
    – “Translate” for “Fields Group” and
    – “Do nothing” for “Fields””

    I am working most with repeaters, and dynamically added fields. I guess these populated fields are being a little cumbersome sometimes – since there is a “dont translate”, “copy”, “translate” setting for each field generated.

    Sometimes I of course wish to copy all content from the originating language – especially when repeaters are used – since the new language most often want the same structure.

    I have been running some javascript in the Chromes Console. So that ALL fields-labels in “Settings for Multilingual content” easily can be set to “copy”-mode, and then revert them all to “Translate”. Since these settings for each field otherwise must be done one by one.

    But it is not a optimal solution, if there only were a few custom meta-data – then it is no problem. But my sites tends to be built with repeaters, blocks, columns – and all through ACF of course (WordPress would not be cool if there were no ACF 😉

  • hey,

    i have pretty much the same issue.

    After setting “translate” for “field groups” and
    “do nothing” for “fields”
    at wpml options
    I can now create independent acf’s for the translation with independent field_names. saving here works…

    on a page/post i can copy the acfs with content to the translated page but when i edit the translated page it always gets overwritten by the acf’s from the default language page.

    trying to achieve:
    i need to copy content with acfs from a default language post to a translated language post. and then edit each language’s acf independently

    On every other project it just works fine that way…

    i already tried:

    1. 1)
      https://wpml.org/forums/topic/post-need-update-and-custom-field-dont-save-value/page/2/
      no success
    2. 2)
      http://support.advancedcustomfields.com/forums/topic/text-area-fields-are-not-saving-on-update/
      no success
    3. 3)
      deleting wpml completely and deactivating acf and all other plugins.
      then install wpml first and then activate acf again.
      no success.
    4. 4)
      tried every possible combination of settings in both plugins available.
      no success

    I can provide some login values to you elliot so you can test the bug and hopefully solve it!

    My next step would be to downgrade acf to an earlier version.

    versions:
    wpml: 3.1.7.2
    acf: 5.0.9
    wordpress: 4.0

    greetings timotheus

  • SAME HERE! Anyone got a solution ?

  • Same issue as well! And worst, when I tried to save a page in French, I got an error 404 page not found… On update go to http://dev.fredericsune.com/wp-admin/post.php instead of ?post=xxxx&action=edit&lang=fr. I tried to rebuilt the permalink structure, don’t translate fields – translate group fields, everything I can imagine of and still, error 404 and unable to save.

  • I have the same problem,
    In the database I see field_keys are saved in the orginal post, but in the translated post not, maybe this is the problem?

  • This did the trick:

    I was helped out by this comment:

    “We had to check
    – “Translate” for “Fields Group” and
    – “Do nothing” for “Fields””

  • I tried “We had to check
    – “Translate” for “Fields Group” and
    – “Do nothing” for “Fields” but it’s worst…

  • Hi Guys

    It seems like there are 2 things which are causing WPML issues. I will write up a guide in the docs to help future users:

    1. The “Field Groups” must be enabled for translation, and a field group must exist for each language.
    2. When editing a post, make sure all custom fields in the ‘Multilingual Content Setup’ metabox are set to ‘Translate’ and not ‘Copy’, otherwise the values will not be updated.

    Hope his helps,

    All WPML tests seems to be working great on my end.

  • Hey guys.

    Just finished writing this article:
    http://www.advancedcustomfields.com/resources/multilingual-custom-fields/

    Please let me know if it is helpful or can be improved in any way.

    Thanks
    E

Viewing 25 posts - 1 through 25 (of 41 total)

You must be logged in to reply to this topic.