Support

Account

Home Forums General Issues Internal links in ACF fields are getting automatically changed to https Reply To: Internal links in ACF fields are getting automatically changed to https

  • The fields were WYSIWYG.

    I did get this sorted out. In case anyone else has the same issue on a site hosted at WP Engine, I’ll put the fix below.

    In WP Engine’s control panel, under SSL, I had to use the following:

    Uncheck “Force http:// for non-SSL pages” – if this is checked I was getting a redirect trying to log in.

    Select “Use SSL for WP-login” – don’t select the one that includes WP-admin. WP-login only does keep WP-admin https too so I’m not sure what the difference is, but the one that includes WP-admin sets the β€œSite Address (URL)” to use https://, WP-login only does not.

    With these settings, the admin pages are still https, but internal site links in ACF WYSIWYG fields do not get automatically converted to https when resaving. This was happening on 3 sites at WP Engine so I don’t think it was a one off weird configuration or anything.