Home Forums General Issues Internal links in ACF fields are getting automatically changed to https


Internal links in ACF fields are getting automatically changed to https

  • Hi,

    I have a quick question. Do you use the “Site Address (URL)” to set all internal links? I have a site with wp-admin set to force SSL, which is causing the “Site Address (URL)” to start with https (trying to set to http doesn’t change this setting – at least not on two sites hosted at WP Engine).

    All internal links in ACF fields on these sites are getting automatically set to https. Changing to http manually when editing a page works, but when the page is loaded again in editor, all internal links start with https again. Internal links in the regular WP Content field do not get converted to https – only ACF fields.

    I’m trying to debug this and figure out if it’s something in ACF or an issue with how WP Engine sets up its force admin to use SSL. If you can let me know if ACF relies on the “Site Address (URL)” it will help get me set in the right direction. Most of the public facing pages are not https – just the checkout and account pages – so the internal https links are causing a bounce from https to http which the SEO agency working on the site doesn’t like.

    Thank you for an awesome plugin! It is the one plugin I could not do without and I use it way more than any other plugin.

    Thank you!

  • Bridget,

    What type of fields are the URLs getting changed for? That would help narrow it down a bit.

  • The fields were WYSIWYG.

    I did get this sorted out. In case anyone else has the same issue on a site hosted at WP Engine, I’ll put the fix below.

    In WP Engine’s control panel, under SSL, I had to use the following:

    Uncheck “Force http:// for non-SSL pages” – if this is checked I was getting a redirect trying to log in.

    Select “Use SSL for WP-login” – don’t select the one that includes WP-admin. WP-login only does keep WP-admin https too so I’m not sure what the difference is, but the one that includes WP-admin sets the “Site Address (URL)” to use https://, WP-login only does not.

    With these settings, the admin pages are still https, but internal site links in ACF WYSIWYG fields do not get automatically converted to https when resaving. This was happening on 3 sites at WP Engine so I don’t think it was a one off weird configuration or anything.

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Internal links in ACF fields are getting automatically changed to https’ is closed to new replies.