Home Forums Bug Reports wysiwyg visual editor not working on WP 5.6


wysiwyg visual editor not working on WP 5.6

  • Although I can see my old posts content and my draft posts content on the Text Editor, the Visual Editor is showing completely blank. I’ve tried to deactivate all my plugins and change my Theme to the Default WP Theme without any success. I’ve also tried to reinstall WP 5.6 version. No effect as well.

    When I hover the cursor over the ACF Visual Editor it doesn’t even gives me the option to click on the field, there’s just an arrow floating over it as it were a non clickable field. When I change to the text field I can see the text cursor option to click over it and do any modifications I wish.

    What’s even more crazy is that is some specific posts, when I visit them for the first time now, the Visual Editor does works properly but, when I leace the post and return later, it’s not working anymore.

    I’ve attached an image where I left the upper ACF on the Text Editor, working perfectly, and the below ACF on the Visual Editor, that’s showing blank.

    Does anybody knows what could be happening over here?

    I’d be very grateful if you could help me,



  • The image didn’t upload in the first post, so here it goes now.

  • Hello there!
    Activate the ‘Classic Editor’ plugin. Had the same problem and this worked for me.


  • I can confirm this bug. Enabling the classic editor plugin did in fact fix the bug, but for only the ‘first’ WYSIWYG custom field. Additional WYSIWYG fields lost the editor buttons? And there’s still a weird bug hiding the content unless you toggle back and forth between the Visual and HTML editors.

    Thanks for all of your work on this amazing plugin!

  • I can also confirm this issue. ACF Wysiwyg field “Visual” editor content not displayed or editable on WP5.5+ (field displayed in an Sidebar position in the block editor, in this case). When Classic Editor plugin is installed, it works again.

  • Same here. It worked well, but the display editor stopped working for me this week.
    Oddly it works well on the options page, but not at all in post creation. It is quite a big issue for me, since my client is adding posts himself.

    I hope the developers will address it soon.

  • I am having the same issue. If WYSIWYG field is used in Gutenberg with position set to ‘Side’, WYSIWYG field is editable at first, but if you select any blocks in the page changing the Gutenberg sidebar tab to ‘Block’ instead of ‘Page’ (taking the WYSIWYG field out of view), and then go back to the ‘Page’ sidebar tab, the WYSIWYG Visual tab is not editable and any content in the Visual tab is gone. However the ‘Text’ WYSIWYG tab does contain its content.

    I verified not a plugin or theme conflict by using Twenty Twenty One theme with all plugins deactivated except ACF Pro.

  • I too have this problem, specifically only in Firefox though – has this been resolved at all? Thank you.

  • Same issue, Any fix already?

  • How could I correct the errors ?

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.