Support

Account

Home Forums Bug Reports WYSIWYG Error

Solving

WYSIWYG Error

  • Just ran into this in WordPress 3.8.1:

    I’m using the Roots starter theme with a few normal plugins including WordFence, Yoast SEO, Responsive Lightbox, ACF, ACF WordPress WYSIWYG, Backup Buddy.

    I setup an ACF field group to include three separate WYSIWYG WordPress text editors for a page template. When I created a new page with the template, all of the editors defaulted to the Text tab, and would not let me click back over to visual. Also, adding media to the second one would oddly only appear in the first one.

    Happened on more than one new and existing page.

    I changed them to the normal WYSIWYG editor, and things were fine.

  • I just encountered this same issue and cannot seem to fix it. No errors showing up in the Chrome console to indicate any kind of conflict or Javascript error. Stock standard theme with no other plugins installed except Advanced Custom Fields and my purchased premium addons.

    I am using the latest version of WordPress as well (auto-updated).

    I am trying to use the WYSIWYG editor inside of a Flexible Content Field. I’ve tried both full and basic modes for the toolbar, also enabling and disabling the media upload button.

    No formatting buttons seem to appear above the editor whatsoever. The formatting toolbar has vanished. Weirdly, if I say yes to having a media upload button, it does show, but it is the only button you can see. The content editor section itself is showing me HTML code, not the styled view you would usually expect from a WYSIWYG editor. It is acting like the text tab has been clicked as opposed to the default visual tab. It’s almost like the editor isn’t being applied at all.

    At first I thought maybe it was the Flexible Content Field functionality breaking the editor, but then I tried just adding in a standalone field and seeing if that worked, but the editor was also broken there as well. I also tried various combinations and embedding within the repeater field and whatnot.

    Is this a known issue? I couldn’t find much out there in regards to info or other people having this issue except this topic.

  • I’m seeing the same issue:

    No formatting buttons seem to appear above the editor whatsoever. The formatting toolbar has vanished. Weirdly, if I say yes to having a media upload button, it does show, but it is the only button you can see.
    -Vheissu

    WP 3.8.3 Multisite install
    Custom theme
    Only plugins are time.ly calendar and Column Shortcodes

  • Has there been an update to this? anyone find a workaround?

    This too is happening for me…

    No formatting buttons seem to appear above the editor whatsoever. The formatting toolbar has vanished. Weirdly, if I say yes to having a media upload button, it does show, but it is the only button you can see.
    -Vheissu

    conditions:
    WP 3.9.1
    Only plugin enable is ACF, when disabled issue is gone
    custom theme

    Works here:
    WP 3.7.3
    lots of plugins enabled
    same custom theme

  • I have the same issue. I sent a support ticket in.

    This is able to be reproduced by following these steps:
    1 – select any page that has a normal WP content editor and switch the tab to “Text”
    2 – leave that page by selecting pages (this seems to be important, maybe preference is set)
    3 – select a page that has an ACF WYSIWYG editor and notice that it’s text editor, but without any buttons. It’s basically the “html” modal that pops up when you click the html button in ACF’s WYSIWYG full editor.

    WP 3.9.1
    ACF 4.3.8

  • Hello,
    Has anyone been able to fix this? I am seeing the same issue. It’s definitely this plugin because I disable it and I can use and see everything in the Visual tab just fine, and then I enable it, and I can’t see anything on the Visual tab.

    Anyone able to fix this?

  • I do have 3.9 installed, this seemed to coincide with when there was a conflict. I also tried to install the Advanced Custom Fields: WP WYSIWYG from Elliot to see if that would help, but unfortunately it did not.

  • I ran into this same bug today after upgrading to ACF Pro 5.05.

  • Any updates on this?

    I am also getting the same results of ‘Add Media’ and ‘Add Form’ (from Formidable plugin), but not the WYSIWYG toolbar?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.