Support

Account

Home Forums Backend Issues (wp-admin) Wysiwyg Editor not insert shortcode

Solving

Wysiwyg Editor not insert shortcode

    • JAVOB

    • September 9, 2013 at 3:24 pm

    Hi I have a shortcode that adds an icon in the editor and when you push a window to fill the options that it has, once released there is a button to insert the code in the editor, as well when pressed does not enter the code editor and you leave it empty, and I’ve noticed that no matter the field wysiwyg editor where you want to insert this code always enters the code in the default content editor that comes with WordPress.

    Is there any solution for this?

    PS: I use the Pro Shortcode plugin, but this happens with any shortcode that inserts an icon in the editor.

    • Elliot

    • September 10, 2013 at 4:09 pm

    Hi @javob

    Thanks for the feedback.

    Just 1 question. Can you first click into the ACF WYSIWYG field and type a few characters, then click the shortcode button.

    Does the shortcode appear in the correct WYSIWYG when it is correctly focused?

    • JAVOB

    • September 12, 2013 at 8:51 am

    Hi @elliot I have tried as you told me but even so still not working, writing the shortcode in the default content editor.

    For more than hidden content editor.

    Can you help me with a solution?

    • Elliot

    • September 14, 2013 at 1:02 pm

    Hi @javob

    I suspect the issue is due to the way that ACF instantiates the WP tinymce. Due to the requirements of the repeater and flexible content field, the WYSIWYG field must be duplicate-able at run time, which the default WP WYSIWYG does not offer.

    I have a feeling that if install and use the WP WYSIWYG field (add-on) your shortcode button will work as expected. If not, the issue most likely lies within the shortcode plugin as it expects only 1 wysiwyg on the page.

    Try out the add-on but be aware it won’t work within a repeater / flexible content field.

    Thanks
    E

    • hoppy

    • September 16, 2013 at 5:00 am

    I guess I have a similar issue, Jetpack shortcodes (http://jetpack.me/support/shortcode-embeds/) do not render in ACF fields, wysiwyg or text. Is there any workaround?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.