Home Forums Backend Issues (wp-admin) Wysiwyg Editor not appearing in edit page


Wysiwyg Editor not appearing in edit page

  • My ACF plugin not displaying Wysiwyg editor in edit page. I’m using ACF version 4.3.1 . It is possible to choose Wysiwyg editor from custom filed, but it’s not appearing in edit page(showing textarea only). The chrome console shows following error:
    Uncaught TypeError: Object #<Object> has no method ‘getBody’ input.min.js?ver=4.3.1:13
    Uncaught TypeError: Cannot set property ‘theme_advanced_buttons1’ of undefined input.min.js?ver=4.3.1:13

    Attached an image from wp backend.

    Any help?. Also is there any way to integrate CKeditor in ACF ?

    Thanks in advance.

  • Firebug shows a different erro message:

    TypeError: n.getBody is not a function

    TypeError: tinyMCE.settings is undefined

    Attached screenshot

  • I found the issue, it was because I installed ckeditor wordpress plugin. Due to javascript conflict native Wysiwyg editor of ACF disabled. After disabling ckeditor plugin. ACF Wysiyg editor working properly.

  • Hi @Sreejesh

    Thanks for the info and solution.
    I’ll add this to the to-do and hope to find some better compatibility


Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Wysiwyg Editor not appearing in edit page’ is closed to new replies.