Support

Account

Home Forums Backend Issues (wp-admin) WYSIWYG Editor Fails To Load

Solved

WYSIWYG Editor Fails To Load

  • I am using ACF with TinyMCE Advanced Plugin and normally it would work. But just recently it seems that the WYSIWYG editor is no longer appearing. I disabled the TinyMCE Advanced plugin to see if it was an issue with that plugin and would load the default wordpress WYSIWYG editor but that didn’t work either. I then looked at the page inspector on chrome and saw that there was a javascript error in the input.js file with in the ACF plugin.

    Screenshot of error.

    And this is what it looks like when the WYSIWYG doesn’t load up and I must say it is somewhat graceful when it breaks.
    The WYSIWYG doesn't load.

  • Hi @matthewary

    Thanks for the bug report.

    I’ll take a look at the compatibility with tinymce advanced plugin int the future.

    Thanks
    E

  • Hi there Elliot. Thanks for your great work. I just wanted to point out that it’s not working with TinyMCE Advanced disabled either and that the input.js file that is throwing the error is part of your plugin located at plugins/advanced-custom-fields/js/input.min.js

    On my screen cap of the error I am pretty printing the minified Javascript for readability.

    I uninstalled TinyMCE Advanced and it did not fix the problem.

    I also tried uninstalling and reinstalling the ACF plugin on a cloned copy of my wordpress site. It did not change the end result, also surprisingly I did not lose any fields or data when I did the uninstall/reinstall.

    Do you have any tips for me to troubleshoot this problem? Is there any information that you could use to pinpoint the issue that I am experiencing?

    Thanks so much for your help.

  • Hello Elliot,

    I just wanted to let you know that installing this https://github.com/elliotcondon/acf-wordpress-wysiwyg-field
    fixed my issue.

    EDIT: I was wrong this did not fix the issue. And I cannot uncheck solved on this bug tracker.

  • Hi Elliot,

    Same problem here, I believe this should be marked as not resolved, as Matthew reports in his edit above, it’s not solved for him either.

    TinyMCE does not load on posts where ACF WYSIWYG field is enabled.
    I too initially had a problem because I was trying it with TinyMCE advanced, but I just tried ACF on an installation without that plugin, and the tinyMCE is still disabled

  • Hi guys.

    Can you please try using ACF on a fresh install. Does WYSIWYG work?

    If so, the issue is sure to be a conflict with a plugin or theme you are using.

    Ad in the plugins 1 at a time until you get the issue. This will pin point the issue and you can then find a resolution

    Good luck!

  • There is something weird going on. If I use https://github.com/elliotcondon/acf-wordpress-wysiwyg-field and apply it to just one field. It seems to fix the problem for the rest of them. Only one field needs to be using the WYSIWYG loaded through this plugin and the rest of them will work using the normal WYSIWYG field in ACF.

  • I am having this problem as well, I like this plugin a lot but I can’t keep using it if my users can’t edit posts pages properly. Is there a fix in sight?

  • The disappearing WYSIWYG problem just recurred for me today with a new install of ACF. I’m sure everybody’s working hard on v5 but this is a pretty serious issue – you can’t have a plugin that creates more fields, taking fields out!

    ACF itself is *definitely* the source of the problem – I just removed all plugins and added them back one by one. Even without ACF Repeater and Options, only basic ACF seems to cause #postdivrich to load with display:none; – this seems to originate at the top of post.php itself, but my detective skills are lacking here.

    Overriding #postdivrich { display:none; } in the developer console causes the WYSIWYG to reappear.

    I just tried a hack, hooking on admin_init, where i force the display: block; style with !important, that works.

    
    function nim_show_editor(){ ?>
    	<style type="text/css">
    		#postdivrich {display: block !important;}
    	</style> <?php
    }
    add_action('admin_init', 'nim_show_editor');
    
  • Thank you andrnimm 🙂
    Your answer is perfect for me

  • I seem to be experiencing the same problem. Was there any further development on this or did it just stop at the admin_init patch? It’s a great work around, but I have this irrational need to know what caused the problem and some version of a “Best Practices” solution.

  • I just ran into the same issue. The hack by andrnimm works but then the images in the media backend do not show up. If I comment the hack out, the images show again.

    Is there a fix by the acf maintainer that works without side effects?

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘WYSIWYG Editor Fails To Load’ is closed to new replies.