Support

Account

Home Forums Backend Issues (wp-admin) WYSIWYG broken with repeater

Helping

WYSIWYG broken with repeater

  • Hi Elliot, just want to say how much I love your plugin. It has improved my workflow tremendously.

    My issue is with the WP WYSIWYG add on, in conjunction with the repeater. Here is my setup:

    Have a field group called ‘content’, which has a repeater field called ‘rows’, whose sub field is a repeater field called ‘columns’. ‘columns’ has two sub fields: 1. WP WYSIWYG called ‘column content’ and 2. Number called ‘column width’. The idea is to add a row with multiple columns inside of it, each with their own WP WYSIWYG editor.

    When I create a new post, or open a post that does not have any ‘columns’ added to it, and I click “add column” to add a repeater field including the WP WYSIWYG – initially it will load the WYSIWYG but not allow me to type into the text area. if i click the text button to toggle to text mode(instead of visual), nothing happens. If I update the post, when it reloads, everything works as it should in the WYSIWYG.

    Once I have clicked ‘text’ once, and it remembers that I want to edit that way, it will always load WYSIWYG editors to ‘text’ mode, but when I click the visual tab, I get an error in the console:

    Uncaught TypeError: Cannot read property 'canvas' of undefined load-scripts.php?c=1&load%5B%5D=hoverIntent,common,admin-bar,schedule,wp-aj…log&load%5B%5D=,wpdialogs,wplink,wpdialogs-popup,wp-fullscreen&ver=3.6:446
    c.closeAllTags load-scripts.php?c=1&load%5B%5D=hoverIntent,common,admin-bar,schedule,wp-aj…log&load%5B%5D=,wpdialogs,wplink,wpdialogs-popup,wp-fullscreen&ver=3.6:446
    switchEditors.go load-scripts.php?c=1&load%5B%5D=hoverIntent,common,admin-bar,schedule,wp-aj…log&load%5B%5D=,wpdialogs,wplink,wpdialogs-popup,wp-fullscreen&ver=3.6:445
    switchEditors.switchto load-scripts.php?c=1&load%5B%5D=hoverIntent,common,admin-bar,schedule,wp-aj…log&load%5B%5D=,wpdialogs,wplink,wpdialogs-popup,wp-fullscreen&ver=3.6:445
    onclick post.php?post=51&action=edit:1

    then when I update the post, everything is fine again.

    I tried loading the WP WYSIWYG editor to a post without the repeater field, and it works as it should, so it is a problem with the repeater field loading the WYSIWYG editor, as far as I can tell.

    I’m suppressing the content editor on the page, and thought that perhaps if I didn’t suppress it, the problem would be fixed, but it persists even if wp loads its native content editor.

    WP 3.6
    ACF 4.2.2
    repeater add on
    WP WYSIWYG add on
    all other plugins turned off

    If it were just me, I could live with it, but my clients will have a hard time troubleshooting this. Thanks so much for your time

    • Elliot

    • September 10, 2013 at 12:42 pm

    Hi @gregnemes

    The WP WYSIWYG field (different to the default WYSIWYG field) does not work within the repeater field. This is stated on the add-on page:
    http://www.advancedcustomfields.com/add-ons/wordpress-wysiwyg/

    It is not possible to get it to work as a sub field due to the way in which it is created via PHP – rather than JS.

    Thanks
    E

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.