Home Forums ACF PRO WPML don't save custom fields


WPML don't save custom fields

  • I read several thread about WPML problems but I can’t figured out how to solve.
    Custom fields are not saved in translated post.
    I can see custom fields in backend but when I insert values and I save the field go back “blank”.

    Please, how can I fix this issue ?

  • did you duplicate the post from the original language or did you use the + button to add the translation? When you duplicate you have to click the “translate independantly” button or else it will not translate.

  • of course I did!!!
    I already tried both.

    Clicking + it give me blank field and when i insert some datas and save then field come back blank.

    Clicking “duplicate” and then “translate indipendently” give me fields filled with same content of original language, then i change field but it comes back to original language value.

    I can give you my credentials if you want to test it yourself!
    Waiting your help.

  • Hello, I have exactly the same issue. Not only on pages but also on the Options page. I create one in French and one in English and the French one doesn’t save at all. I can provide access to my dev environment if needed.

  • Maybe nobody matters… Here waiting a solution and no answer, nobody saying… I can watch it … I don’t know…

  • Question is:
    should “group fields” be translatable in wpml options ?
    If i fix “group fields” not translatble it works but then… how can i translate field labels ?

  • I have the same problem,
    In the database I see field_keys are saved in the orginal post, but in the translated post not, maybe this is the problem?

  • In WPML I set the ‘field groups’ to translate. Then you translate the field group in ACF (just duplicate or copy). You don’t have to change anything, they just need to be translated.

    Which versions of WPML and ACF do you use?

    I can take a look at your settings if you want.

  • Hey guys.

    I’ve just put together a bit of a guide for WPML. Can you please give it a read and let me know if it helps?


  • Hi Elliot,

    Thanks for the explanation page. I always set things up the same way and it works for me.


  • This is the solution, thanks. You should give it more visibiliy!

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘WPML don't save custom fields’ is closed to new replies.