Support

Account

Home Forums Bug Reports User field doesn't populate (for non admins)

Solving

User field doesn't populate (for non admins)

    • TCattd

    • August 15, 2019 at 12:41 am

    Hi,

    Have an issue, and can’t find the root cause of this. Any help will be appreciated.

    We have an User field, setup like this:
    https://prnt.sc/osmk7o

    That field should be displayed at WooCommerce’s orders. And it does:
    https://prnt.sc/osmlns

    But the field is only populated correctly when an admin is logged in and he views the order.
    When a non admin user is logged in and view an order, for example a shop manager (from WooCommerce), the field shows up, but no user is listed on the select-search:
    https://prnt.sc/osmnhl

    I already tested disabling all the plugins, except for ACF and WooCommerce, and the result is the same.
    Tested it in a clean WP with just Storefront theme, WooCommerce and ACF Pro enabled, and same result. No users in the metabox (for a field setup like the screenshot) if you are logged in as a non admin user.

    It’s a bug? Or i’m missing something else?

    Thanks in advance for the time and help.

    Esteban

    • TCattd

    • August 16, 2019 at 11:29 pm

    Forgot to mention that roles is something that i already checked.

    By default, Shop Manager has the capability list_users, and as you can see here https://prnt.sc/otih6r it’s given properly there where i’m testing this.

    And even if i give Shop Managers the entire Users capabilities (all of them), the box still doesn’t populate with any user at all.

  • Hi! I also have a similar issue with a custom select that shows users in a given role on a WooCommerce order.

    I thought I had fixed it by emptying the browser cache and hard reloading, but some people have had the issue return. I’m going to investigate today and see if I can clarify the cause.

    Just thought I would add a post here so you know you’re not alone! 😉

  • Hmmm, giving list_users to people in the group worked for me.

    Have you double checked that people are in the right roles?

    • vizou

    • October 23, 2019 at 7:41 am

    I have the same problem when outputting custom user meta fields to the BBPress User Profile page. It outputs the values of those fields perfectly for anyone who has Admin role but for lower roles, even though the data is there, it doesn’t output. I am wondering if it has to do with the Permissions set on the Field Group (Add/Edit, Admin) but I thought this only affected the EDITING of those fields. Help?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.