Support

Account

Home Forums Bug Reports Uploading images does not work after 5.0.8 update

Solving

Uploading images does not work after 5.0.8 update

  • WP 4.0
    ACF Pro 5.0.8

    Uploading images does not work anymore with the latest upgrades.

    The media library is triggered but when selecting the image, the following error pops up in my console: Uncaught Error: A "url" property or function must be specified in Backbone.

    There is an interesting stack trace leading to acf.fields.image.acf.field.extend.render in input.js line 4413 , acf.media.popup.select in input.js line 4394, (anonymous function) in input.js line 1896 and further down (anonymous function) in input.js 1892…

    Not very helpful if you can’t reproduce the bug…

    Cheers.

  • I’m seeing the same thing as well.

  • Yes same issue on 5.0.8

    If I revert back to 5.0.7, they reappear.

  • Forgot to mention that it works fine with WP 4.0 and ACF 5.0.7…

  • WP 4.0 + ACF PRO 5.0.7 = OK
    WP 4.0 + ACF PRO 5.0.8 = Exact issue described above

    I’m not in a position to “disable all other plugins” but I can say that the two parallel installations I have are exactly the same, except for the ACF PRO version. One works, one does not.

  • Forgot to mention I have only ACF running…
    I’ll probably post one more “Forgot to mention…” later on.

  • Im having the same issue. Im trying to add a png to an image field. It works fine with a jpg i uploaded yesterday.

    Don’t know if this helps:
    Animated gif example

  • There is another topic in this forum regarding the same problem. This is what I posted there:

    Okay, here’s a quick workaround until the bug has been resolved:

    In the admin panel where the field groups and fields are defined, you have to set the preview image of each image field to “thumbnail”. After that, the upload/selection of an image won’t fail anymore. Except the uploaded image is even smaller than 150×150 pixels (the standard size of the WordPress thumbnails).

    As long as it’s larger than that, you’re fine.

    It’s not a real fix, though, and I hope the bug will be resolved soon.

  • In my instance because the images I uploaded were too small (icons) they don’t have WP sizes so I had to set the image size to “full.” Apparently it doesn’t have any URL fallback for images sizes anymore… Same thing, only since 5.0.8

    Thanks for Supernovae for your insight on this, helped me get a solution.

  • Just chiming in here that I’m getting the exact same error. WP 4.0, ACF 5.0.8.

  • good call @xtremefaith, changing size of the preview to full seems to be a good temporary fix

  • Elliot has released a fix for this issue, just re download version 5.0.8 and install. Worked for me :). You can also access previous version from the My Account page.

  • Same issue here. Elliot any chance for 5.0.9 to fix this on the pro version? I have this on quite a few client sites and manually reverting to 5.0.7 on all of them is not going to be a fun task. Would be so much easier if I can just update the plugin to get the bug fix. I just went through them all and updated to V5 from V4 yesterday not looking forward to doing it again 😉

  • Reinstalling 5.0.8 didn’t work, but rolling back to 5.0.7 did the trick just fine.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.