Support

Account

Home Forums General Issues Upgrade to ACF 5.7.6, Website now broken

Solving

Upgrade to ACF 5.7.6, Website now broken

  • Hi, I just updated a client website to the latest ACF version, 5.7.6 but now the entire site is broken and all content has gone missing. πŸ™

    This is a website that I “inherited” from another design company after they had built it but not finished it so its not designed/built how I would set it up but I can only work with what I have now.

    The website had the free ACF plugin installed, but also had the following components added by the original design company, which I assume were paid for add-ons:

    Flexible Content Field, Location Field, Options Page and Repeater Field.

    And since upgrading nothing is working anymore.

    All content just shows this:

    Warning: Illegal string offset ‘acf_fc_layout’ in /var/xxxxx/x/xxxxxxx.co.uk/public_html/wp-content/themes/themename/functions.php on line 379

    -or-

    Warning: Illegal string offset ‘acf_fc_layout’ in /var/xxxxx/x/xxxxxxx. co.uk/public_html/wp-content/themes/themename/content-fcp.php on line 6

    I no longer have any field groups showing or any way of editing content – if I edit a page nothing shows up except for an empty meta box called “Flexible Content”.

    I’m guessing this means I now have to pay to upgrade to the Pro ACF version which seems to include those fields?

    So what happens for sites like this that had all the original add-ons installed?

    I’ve asked the hosts to roll back the site to the last backup to avoid the issue for now as I know my client won’t want to pay to upgrade anything at this stage, but I would like to fix it going forward.

    If we do move to the Pro version, will it revert back to the original content?

    Thanks.

  • Rolling back to ACF4 is what you need to do and then send support an email to support here https://www.advancedcustomfields.com/contact/.

    As a side note, all of the add-ons that you mentioned for the free version should be upgraded as well and they should all still work.

    But the best bet when having issues with the upgrade is to contact support at the above link.

  • Thanks, we have rolled the website back to ACF 4.4.12 which is working fine now.

    Strangely enough I can now also see updates for the add-ons in the updates section which weren’t there before.

    I wonder if I update the add-ons first and then update ACF to 5 it would then work as planned?

    I will setup a dev version of the site to try it out first I think.

    • Elliot

    • September 18, 2018 at 10:21 am

    Hi @harofreestyler

    Testing on a dev site is always a good idea, but is it possible that you forgot to run the DB upgrade after updating the plugin?

    Please be sure to read over the upgrade guide here:
    https://www.advancedcustomfields.com/resources/upgrade-guide-version-5/

    Let me know how you go.

    • johnroe

    • September 18, 2018 at 1:29 pm

    I have the same issue. There is no “Upgrade database” button after upgraded the plugin.

    • loorlab

    • September 18, 2018 at 2:41 pm
    This reply has been marked as private.
    • Elliot

    • September 18, 2018 at 4:57 pm

    Hi @johnroe @loorlab

    After upgrading a website from ACF4 to ACF5 you will be prompted to upgrade the database. This prompt is visible when logged into the website’s dashboard. If for some reason this prompt does not appear, please consider the following possibilities:

    1. You have already upgraded in the past. The upgrade prompt will only run once, even if you have rolled back.
    2. There may be another plugin / theme code hiding the prompt.
    3. Your DB wp_options table contains a modified “acf_version” value.

    An easy way to check if the upgrade has been run in the past is to check your database wp_options table and find the “acf_version” row. This option contains the last known version of ACF installed. If the version is higher than 5.0, the upgrade has already run and will not appear.

    It is possible to force ACF to run the upgrade again by editing this row in your DB and changing the option value to “4.4.12”. Please be sure to backup your database before making this change to avoid any “duplicate data” created in the second upgrade.

    For now, you can always rollback to ACF4. There is no data loss with this and is a good solution to get your site working until you can test the update on a dev/staging site.
    https://www.advancedcustomfields.com/resources/upgrade-guide-version-5/

    If you’re still having troubles, please contact support.
    http://www.advancedcustomfields.com/contact/

  • Yes I upgraded the database.

    I actually have ACF on about 9 websites and had already done all of those sites and upgraded the databases on those so was aware of the process, it was this final website that failed.

    I will try doing it on a dev site next week and see what happens.

  • Just to add to this and to help the two guys above, on some of the sites I upgraded the “Upgrade Database” button didn’t show up at first, it only showed up when I clicked back into the Updates section.

  • How do I go back to v4 please? Instructions?
    I’m having the same problem – not all but some data gone.
    The weird thing is that everything was fine this morning, but now at midday some of the links to downloadable JPG and PDF files are showing “not found”. The problem is happening on first level pages but not at deeper level pages.

    Thank you,
    Catherine

  • Instructions for going back to 4 are in the troubleshooting section of the upgrade guide here https://www.advancedcustomfields.com/resources/upgrade-guide-version-5/#troubleshooting

  • Thank you. I installed version 4 and that did not change anything. Also, why would higher level pages have the problem, and deeper level pages be working fine?

    Examples:
    1. click “Family Sell Sheet” = file not found
    https://broncowine.com/product-category/national/national-all/sixdegrees-national-all/

    2. Same link; click on a bottle, then click any of the links below = works fine

    Everything was fine before upgrading. How do I get things to work again please?
    Thanks,
    Catherine

    • bury

    • October 16, 2018 at 11:10 pm

    Same for me. After automatic update everything was broken. The Update Database Button appears, after that update the site works, but half of the content disappeared. I reverted with complete restore to 4.4.12 and dont see a way to update to ACF 5 without completely rewriting our site, which I wont do. If support will have a look to this error, I can give you credentials, full updates which are capable of doing a restore to a healthy situation are available.

  • @bury please see the troubleshooting section https://www.advancedcustomfields.com/resources/upgrade-guide-version-5/#troubleshooting

    If you need help there are links there for contacting support for the kind of help you are looking for.

    • bury

    • October 16, 2018 at 11:26 pm

    I already tried everything in the troubleshooter and tried 3 times to install the update, every time with the same result: Half of the content is missing. Good luck that my backup guard is working. The issue disappears only with full restore.

    • bury

    • October 17, 2018 at 12:13 am

    I figured out, that it`s got anything to do with the repeater field addon. If I deactivate it, I got the same issue on 4, half of content is gone. I have already updated this plugin to version 2.1.0, which is running on ACF4 very well. Any suggestions from support?

  • @bury you will need to contact support here https://www.advancedcustomfields.com/contact/. It appears that your issue is beyond my ability to help you on this forum.

    • ericm

    • December 1, 2018 at 10:59 am

    Has anyone figured out the solution to this? I am having the exact same issue. I reached out to support, but they stopped responding to me on November 2nd. I’ve sent them 5 emails since then, but no response.

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.