Support

Account

Home Forums ACF PRO upgrade the database – permission error

Solving

upgrade the database – permission error

  • Hello,
    When we try to access the page below:
    http://server/wp-admin/network/update-core.php?page=acf-upgrade

    We are getting this error:
    “You do not have sufficient permissions to access this page.”

    We are in multisite logged in as Super Admin.

    Please advise.
    Thank you,
    Larisa

  • Hi there,

    I encountered the same issue, running WP locally with Multisite. I couldn’t find any solutions, but I did get to work when I left the plugins area and went back to the main dashboard. I got a pop-up warning about backing up my database, okayed that and then the upgrade worked. Hope this helps.

    If that doesn’t work, go into phpAdmin and in the usermeta table, make sure wp_capabilities is a:1:{s:13:”administrator”;s:1:”1″;} and that wp_user_level is 10. Then try again.

  • *bump*

    I have been stuck in this exact stoppage for the past two months.
    Tried every possible combination of tricks to try to overcome it, but to no avail.

    I’d be glad to document the issue if necessary to help out with the solution.

  • Hi xhezairi,

    Did the database solution I suggested above (pilfered from elsewhere) not work for you? I encountered this issue again recently and it seemed to have been resolved by clicking the ‘upgrade’ button from within one of my sites and not in the network admin area.

  • I can’t get past this on multisite either. I am a super admin, so that is not he problem. I can update WP core. I can’t get this to work. I also don’t get the update button on sites, only on network admin pages.

  • I will be honest. I don’t think this means anything. I think it is just annoying. I already upgraded all of the sites. And I don’t see anything specifically triggering this, so it just seems like this shows up in the latest version for no good reason. I am moving on and forcing it off. Add this somewhere to remove it:

    add_filter( 'acf/settings/show_admin', '__return_false' );

    Plugin to apply to network, change info as needed. I saved it to remove-acf-network-admin-notice.php and uploaded the file to my site’s plugins:

    <?php
    
    /**
     * @wordpress-plugin
     * Plugin Name:       Remove ACF Network Admin Notice
     * Description:       Removes the non-working, seamingly senseless upgrade notice in ACF
     * Version:           1.0.0
     * Author:            Jupitercow
     * Author URI:        http://Jupitercow.com/
     * Contributor:       Jake Snyder
     * License:           GPL-2.0+
     * License URI:       http://www.gnu.org/licenses/gpl-2.0.txt
     * Network:           true
     */
    
    add_filter( 'acf/settings/show_admin', '__return_false' );
  • I will note, that you should remain aware that you turned that off in the future and be ready to turn the plugin off in the future when you want to upgrade or this issue is fixed.

  • I am running into this issue on a multisite that I manage also. Same story, logged in as superadmin, can run updates on core. Get an access denied when I try to run the ACF database update. Any solution for this?

  • Hi @aharl ,

    Have you tried the workaround shared by @jcow? Did it work for you?

    If you are still stuck, kindly let me know so that I may be able to help 🙂

  • It isn’t much of a workaround, and just meant to be patch until somebody can figure out why it isn’t working correctly. Currently, it also removes the Custom Fields menu item from child sites, so it isn’t very useable in the end.

    Would love to get this fixed.

  • Yea, I’m wondering how that is a work around. All it is doing is hiding the message to upgrade that takes over the admin area. Is this a message that can be ignored?

  • The issue, I realized, is that I had some sites that did not get upgraded. Basically. This tool doesn’t work. You just need to:

    1. Ignore it.
    2. Go to each site, individually
    3. Upgrade them from there
    4. It should go away.
  • Same problem here on my multi-site installation. Ignoring it seems like the only real option at the moment, clicking through 200 odd sites seems a little time consuming.

  • Did you make sure each site is upgraded? I know on some multisites that can be daunting, but, if possible, that is the best thing you can do: Manually update each site individually.

  • Manually clicking through the 200+ sites in my network will take hours, not really a good solution. For the time being I’ll take your first suggestion and just ignore it, everything appears to be working fine.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.