Home Forums ACF PRO Updating CPT with Custom Field Values Never Completes


Updating CPT with Custom Field Values Never Completes

  • I have a custom post type that contains a bunch of custom fields. Everything was working fine, up until the upgrade to 5.0.4. Now, after editing values, the post “Update” never completes and just spirals continually.

    Also, I have WP_DEBUG set to true and never see any errors. Only ACF 5.0.4 is activated, no other plugins.

    Posts & Pages work fine. I tried re-saving/updating all custom fields and clearing any caches.

    Any ideas?

  • Anyone have any ideas on this one?

  • This is super weird… if I change the CPT-post to “Pending Review” or “Draft” in the Quick Edit options, then edit the page, it accepts and saves the data if I “Save as Pending” (doesn’t work if I hit Publish). Then I can set the status back to “Published” from the Quick Edit panel and the updated data shows up.

  • Hi @fostertime

    Please leave the DEBUG MODE on, and check your console log after you click the publish button.

    ACF will fire an AJAX call to validate the post’s data before submitting the form, you should be able to find the AJAX response. What is it?

  • The fix to this, was actually to change WP_DEBUG to false. After doing that, everything worked fine.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Updating CPT with Custom Field Values Never Completes’ is closed to new replies.