Support

Account

Home Forums Bug Reports Update to 5.5.7 breaks repeater fields

Solved

Update to 5.5.7 breaks repeater fields

  • Hello,

    After upgrading to 5.5.7 whenever I add a field to a repeater field it sets the parent to 0 and the field is then added as a sibling to the repeater field even though it was created as a child of the repeater:

    <input class="input-parent" name="acf_fields[182][parent]" value="0" type="hidden">

    Is this a known issue? It worked perfectly on 5.5.5

    Looking forward to hearing from you

  • Just reverted back to 5.5.5 and everything is working correctly.
    Wanted to be sure that none of my changes were causing this.

    It is definitely the upgrade.

    Please let me know.

  • I’m not seeing this issue on my testing site. Have you tried disabling other plugins or switching themes to see if something else is causing the issue?

  • There is only the 2016 ( stock theme ) and another plugin I built.

    Tried disabling my plugin but it did not do the trick.
    This was one of the first things I tried.

    Switched back to 5.5.5 for the time being. Will update again to 5.5.7, debug and come back with an answer.

    I thought it was a known issue.

    However, thank you for replying.

  • The bug appears to have been fixed in 5.5.8 or 5.5.9

  • Hi I just like to add that updating to 5.5.10 broke already established repeater fields. I reverted back to 5.4.3 and the issue resolved.

    The code:

    if(have_rows('body_sections')) :
    				while(have_rows('body_sections')) : the_row();
    
    					switch(get_sub_field('acf_fc_layout')) :

    In 5.5.10 caused get_sub_field(‘acf_fc_layout’) to be blank. I did not have time to try and debug. I did run the db upgrade routine and resaved the ACF content to see if it fixed it.

  • @atwellpub the sub field you’re trying to get ‘acf_fc_layout’ is this a field you’re created? ACF sets this field in the array of a flex field, but this is not an actual sub field. Are you trying to get the row loayout? I’ve never seen it done this way and as far as I know you should be using https://www.advancedcustomfields.com/resources/get_row_layout/

  • Thanks John I think converting over to those will do it.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.