Support

Account

Home Forums ACF PRO Update from 5.03 to 5.04 fails : update package not available

Solved

Update from 5.03 to 5.04 fails : update package not available

    • rpk

    • August 7, 2014 at 6:53 am

    Hi, the wp install of my present project is noting that there is an update of acf pro (dev license) to version 5.04. But every time i try to update the process fails stating that the update package is not available. The updates before haven’t been any problems at all. Has the package been pulled again and has been removed? Best regards Ralf

    • Elliot

    • August 7, 2014 at 2:14 pm

    Hi @rpk

    Sorry for this issue. I’ve just tried to replicate the issue on my end, but the update is working fine.

    Perhaps this was a temporary glitch?

    Is the update working now?

    • rpk

    • August 7, 2014 at 5:57 pm

    Hi Elliot, no worries at all. Actually i’ve figured out the root of the problem. It wasn’t a temporary glitch, the defined urls for WP_HOME and WP_SITEURL were the reason.

    I am developing locally with MAMP and Codekit 2. When i’ve used e.g. those settings:

    define('WP_HOME', 'http://192.168.0.198:8888/mysite');
    define('WP_SITEURL', 'http://192.168.0.198:8888/mysite');

    even when i’ve set portforwarding for this ip and port i was unable to access the developed site from remote. But a friend suggested me the following:

    define('WP_HOME', 'http://'.$_SERVER["HTTP_HOST"].'/mysite');
    define('WP_SITEURL', 'http://'.$_SERVER["HTTP_HOST"].'/mysite');

    With those definitions i was able that someone else could access my locally developed site from remote. I think since i’ve changed to those $_SERVER["HTTP_HOST"] definitions other updates worked fine but it was the first update with ACF. Now i know the cause but the why i am not sure. 😉 But maybe that helps you to understand my discovered issue better. Should the update basically work with $_SERVER["HTTP_HOST"] or not all and i shall return using local ips? Best regards Ralf

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.