Support

Account

Home Forums Bug Reports Update 5.7.11 Crashes Site

Solved

Update 5.7.11 Crashes Site

  • Updating from ACF Pro 5.7.10 crashes my WordPress version 5.0.3 site.

    The ACF Pro update proceeds normally and finishes. When I attempt to go to another admin tab, the site crashes. Both frontend and backend are not reachable. A review of the database shows ACF still at 5.7.10.

    Only by replacing ACF Pro with 5.7.10 am I able to get back onto my site.

  • I second this report. Escalate please!

    My live site seems to still be alive, but all attempts to reach the admin dashboard return Status 500, WSOD.

    Backed out by uploading a copy of 5.7.10 and the site proceeds normally. This is a bad update. Please advise.

  • I third this report. Escalate further!

    I can only access any part of my site by deactivating 5.7.11, which leads the site to run but without any content. Please advise how to proceed.

    • voala

    • February 12, 2019 at 2:31 am

    Also happened to me just now. I had to get the website under maintenance mode. All content is gone.
    L.E.: I confirm, reverting back to 5.7.10 is working. Will wait for updates on this matter before the update.

  • Hi guys,

    This morning I updated from 5.7.10 to 5.7.11 and any draft page I try to preview doesn’t load properly since the update. The header/footer load fine, but the body (where we use acf pro) shows a white screen.

    Note: I need to have updated to 5.7.11, go to a draft page, save it, then try preview it in order for the error to appear. It wont happen with existing draft pages unless a ‘save draft’ is preformed. Obviously with any new page creations, the error happens on previewing.

    I reverted to 5.7.10 to resolve the issue temporarily until a fix is put in place.

    Thanks guys.

  • Same here. Hope for a quick fix to be released soon.

    • josephd

    • February 12, 2019 at 5:52 am

    I noticed that php referencing ‘register_field_group’ instead of ‘acf_add_local_field_group’ fixed the problem on my end.

    I had exported some PHP to my Parent Theme in 2014 or 2015 and it was broken at this release. swapping out those bits seems to have worked on my website.

    • josephd

    • February 12, 2019 at 5:59 am

    Hi everyone, I noticed the same issue with templates where I had used old exported PHP with references to ‘register_field_group’ vs the current method of ‘acf_add_local_field_group’

    Updating those references seemed to resolve the problem for me.

    • pshay92

    • February 12, 2019 at 7:05 am

    This has happened to me to as well.

    My error log says “PHP Fatal error: Can’t use function return value in write context in /home/ataloholdings/public_html/wp-content/plugins/advanced-custom-fields-pro/includes/local-fields.php on line 304”.

    When I go to that file and comment out the function ‘acf_have_local_fields’, the site is now visible, but none of the custom fields are available in the backend of the pages, and my error log now says ‘Call to undefined function acf_have_local_fields() in /home/ataloholdings/public_html/wp-content/plugins/advanced-custom-fields-pro/includes/acf-field-functions.php on line 346’

    • kokers

    • February 12, 2019 at 7:05 am

    Check your PHP version on server. The only site that crashed for us after update (and I’ve updated ~20 sites) have php 5.4. Waiting for access to hosting panel right now to change it and test it, but if I would take a guess it would be it. So can anyone of you check php version on crashed sites and if changing to some 7ish will solve the issue?

    Reversing to 5.7.10 helped for now on that one site for us.

    • kokers

    • February 12, 2019 at 7:13 am

    I can now confirm that it’s a version PHP 5.4 that cause this issue. Which is old anyway.

    Solution, update your PHP to version 7. Version 5.6 works just fine if you can’t use any of the 7ish, but I highly recommend use most recent available on your server.

    • pshay92

    • February 12, 2019 at 7:18 am

    This worked! Thank you very much.

  • PHP version is NOT the issue on my site. I am running php 7.2, and the update crashes my admin.

    Relevant Woocommerce Status report:

    • voala

    • February 12, 2019 at 8:28 am

    This is not a php version issue. Or at least, not on 5.6. I updated PHP from 5.4 to 5.6 (max on godaddy linux hosting) on a customers website and the issue is still there. Maybe on some higher php versions?

  • My site is running on PHP 7.2 and it crashed. I don’t believe it is a PHP version issue either.

    • kokers

    • February 12, 2019 at 8:46 am

    @pacuk4386 @voala @edward-bernstein Turn on debug log and check what’s the error. Probably you will get something different than:
    “PHP Fatal error: Can’t use function return value in write context in /public_html/wp-content/plugins/advanced-custom-fields-pro/includes/local-fields.php on line 304”.

    I got the same error as @pshay92 so that is why it worked for her. None of you posted any error messages. Please turn WP_DEBUG_LOG if you don’t have it enabled to see what error you get. Since it’s not a php issue for you, any logs will help resolve the problem. https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG_LOG

    @voala I’ve tested this on our hosting on 5.6 its working ok with 5.7.11 but crashes on 5.4, so you must have different issue

    • Elliot

    • February 12, 2019 at 8:58 am

    Hi all.

    Apologies for the errors you are experiencing.
    Let’s get these fixed.

    If your production website is crashing with the latest update, please manually download and restore the ACF PRO 5.7.10 plugin files from your account online: https://www.advancedcustomfields.com/my-account

    To address the issues, please do enable DEBUG MODE and post your logged PHP errors here.

    • Elliot

    • February 12, 2019 at 9:05 am

    Fix for error: “PHP Fatal error: Can’t use function return value in write context in /public_html/wp-content/plugins/advanced-custom-fields-pro/includes/local-fields.php on line 304”.

    Please edit the file in question and change line 304 to:

    
    return acf_get_local_fields($parent) ? true : false;
    

    Reason for error: PHP version 5.4 does not allow expressions, only variables. This was fixed in PHP 5.5.

    • Elliot

    • February 12, 2019 at 9:10 am

    Fix for error: “PHP Fatal error: Uncaught Error: Call to undefined function register_field_group()”

    Please edit the ACF PRO plugin file “includes/local-fields.php” and add the following function on line 184 after acf_add_local_field_group().

    
    /**
     * register_field_group
     *
     * See acf_add_local_field_group().
     *
     * @date	22/1/19
     * @since	5.7.10
     *
     * @param	array $field_group The field group array.
     * @return	void
     */
    function register_field_group( $field_group ) {
    	acf_add_local_field_group( $field_group );
    }
    

    Reason for error: The register_field_group() function was accidentally removed. Adding it back will solve the issue.

  • Here’s the error on my staging site when I installed the new update (Note to self in the future, ALWAYS try updates on the dev site before going live!!)

    This seems to indicate a bug in the WP All Import – ACF plugin.

    Fatal error: Uncaught Error: Call to undefined function acf_local() in /mnt/BLOCKSTORAGE/home/164418.cloudwaysapps.com/kudxrqttwq/public_html/wp-content/plugins/wpai-acf-add-on/wpai-acf-add-on.php:473 Stack trace: #0 /mnt/BLOCKSTORAGE/home/164418.cloudwaysapps.com/kudxrqttwq/public_html/wp-content/plugins/wpai-acf-add-on/wpai-acf-add-on.php(248): PMAI_Plugin::init_available_acf_fields() #1 /mnt/BLOCKSTORAGE/home/164418.cloudwaysapps.com/kudxrqttwq/public_html/wp-includes/class-wp-hook.php(286): PMAI_Plugin->init(”) #2 /mnt/BLOCKSTORAGE/home/164418.cloudwaysapps.com/kudxrqttwq/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #3 /mnt/BLOCKSTORAGE/home/164418.cloudwaysapps.com/kudxrqttwq/public_html/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /mnt/BLOCKSTORAGE/home/164418.cloudwaysapps.com/kudxrqttwq/public_html/wp-settings.php(467): do_action(‘init’) #5 /mnt/BLOCKSTORAGE/home/164418.cloudwaysapps.com/kudxrqttwq/public_html/wp-config.php(96): require_once(‘/mnt/BLOCKSTORA…’ in /mnt/BLOCKSTORAGE/home/164418.cloudwaysapps.com/kudxrqttwq/public_html/wp-content/plugins/wpai-acf-add-on/wpai-acf-add-on.php on line 473

    • go4mm

    • February 12, 2019 at 10:04 am

    Also have a bunch of sites with issues after 5.7.11 upgrade. For reference in my case
    – frontend and backend are still viewable
    – but no ACF (flexible) content shows on the frontend
    – no errors thrown in error logs or via wp_debug
    – reverting to 5.7.10 fixes the issue

    • josephd

    • February 12, 2019 at 10:34 am

    Updating references of ‘register_field_group’ with ‘acf_add_local_field_group’ in my template solved problem on my end.

    Is it okay that I did that?

    Note: I’m still running ACF PRO 5.7.10 due to a cron export conflict with WP All Export. I’m not sure if the two issues are related. Although I do use ACF in that export.

    • Bung55

    • February 12, 2019 at 11:32 am

    I’ve not updated any sites – will there be a 5.7.12 to address these issues (happy to wait, not rush, no need to apply the patches manually!)

    • voala

    • February 12, 2019 at 3:44 pm

    Yes, I get the “PHP Fatal error: Can’t use function return value in write context in /public_html/wp-content/plugins/advanced-custom-fields-pro/includes/local-fields.php on line 304”. Sorry forgot to mention this. If this is indeed a PHP 5.4 related issue, this means godaddy did not update to 5.6, and still runs on 5.4 (even if I did the update). Will check a phpinfo.

    • Elliot

    • February 12, 2019 at 6:48 pm

    Hi all

    My apologies for the issues in version 5.7.11.
    I am confident we have found and fixed the issue.

    Can you please re-download the ACF PRO plugin files and test the issue?

    An easy way to re-download is to edit the main acf.php plugin file and change the version number ‘5.7.11’ down to ‘5.7.10’
    – please note the version number appears twice in this file and both will need to be changed
    – after this change is made, please update the plugin as per normal and it will update to 5.7.11 (including the new fix)

Viewing 25 posts - 1 through 25 (of 30 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.