Support

Account

Home Forums General Issues Uncaught ReferenceError: switchEditors is not defined

Solving

Uncaught ReferenceError: switchEditors is not defined

  • Hi Elliot,

    Have a strange issue going on. My client cannot see the regular content editor on their post/pages. They have the media upload button and raw code, nothing else.

    Console is loggin this: Uncaught ReferenceError: switchEditors is not defined

    Strangest part is that this is only happening in their account — they have an editor role. I don’t see this in my admin role account or in my other editor role account I use for testing.

    Already disabled plugins, not a conflict. Too strange! Ideas??

    • Kevin

    • May 8, 2014 at 8:12 pm

    You can try to duplicate the page via another plugin (or manually if it’s not that big). I did it and it worked for me. Sometimes WordPress has some kind of weird caching especially in Template Names (if you change it in the code it still appears in the dropdown).

    That fixed it for me at least. Because it worked on other pages where ACF still worked well before.

    Best,

    Kevin

  • I’m not sure what your solution is suggesting, this wasn’t an issue with a page or a template, it was happening on the whole site.

    The editor was not working on any page/post etc. but it was only isolated to one WP user account.

    I was ultimately forced to create the client a new user account and delete the old one.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.