Support

Account

Home Forums Backend Issues (wp-admin) Unable to upload images after upgrade to 5.02

Solving

Unable to upload images after upgrade to 5.02

  • We recently updated our site to ACF 5.02 and then this morning after having problems I updated to 5.03 but the problem persists.

    When I try to upload an image, nothing happens. Opening firebug I see the following javscript error:
    TypeError: wp.media.controller.EditImage is not a constructor

    I tried a few tests such as uploading an image in the stock WP media gallery and it worked fine. I then made a separate custom field group without any repeater fields and just an upload image button and tried editng a post it was set to show on but once again I could not upload or even choose any image.

    Without doing too much troubleshooting it strikes me that the javascript that is being called when that button is clicked on is the wrong function. There is no image to edit, I want to upload one like the button says.

  • Same thing for me. I just commented out line 1252 and all seems well for me… not sure what functionality is gone though. I can’t really tell seeing as everything is working.

    Line 1252: new wp.media.controller.EditImage()

  • This happens to me too.

    Dan

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.