Support

Account

Home Forums Backend Issues (wp-admin) Unable to change fields once I’ve created them

Solved

Unable to change fields once I’ve created them

    • Dalton

    • July 19, 2013 at 7:33 am

    I’ve got a problem with the ACF admin on multiple sites. Once I’ve created a field group, I cannot edit them. Can’t change existing fields and can’t add new fields.

    I make the changes, click “Update”, and the message “Field Group Updated” appears. But the actual field value is not modified, or the new field has not been created.

    This started happening recently, maybe with 4.1.7? I’ve tried 4.1.8.1 and 4.2.0 RC 1 pulled straight from GitHub with the same results.

    I can give you admin access to one of these sites if you’d like to see the problem in action.

    • Elliot

    • July 20, 2013 at 11:31 am

    Hi @Dalton

    Are you running any Cache plugins?

    Have you tried disabling them?

    • Dalton

    • July 21, 2013 at 1:23 am

    I’m not running any cache plugins, but the site is on WP Engine, which does cache the front-end aggressively. I didn’t know they cache on the back-end too.

    I have a local copy of the site I’m working on and just checked – it looks like ACF is working as it should on the local site, but not on the WP Engine site. So I guess this might be a WP Engine issue, I’ll check in with them.

    • Elliot

    • July 22, 2013 at 12:36 pm

    Hi @Dalton

    Thanks mate. Can you please post back here when you hear from WP Engine? I would like to make sure we have this issue fixed in the future.

    Cheers
    Elliot

  • I’m experiencing the same issues at you, @Dalton. I’d like to place a ticket with WP Engine as well, do you mind if I can have your ticket number for this issue so I can reference it?

    • Dalton

    • July 23, 2013 at 5:57 am

    I have a ticket open with WP Engine, #124043

    We loaded the site up on a staging server and didn’t experience any problems, so it looks like something’s up with WP Engine’s admin caching. I’ll let you know when I have more info.

    • Dalton

    • July 23, 2013 at 6:09 am

    @Full Circle Design: Christian at WPEngine just did a “reset permissions” for my account and it seems to have fixed the problem. The function is available under the “WPEngine” tab on your WordPress dashboard. Hope that helps!

  • Thanks @Dalton! I think I may have found something else that will help. When logged in to the back end of your WP Engine website, hover over the left-hand menu item and click on WP Engine. Your General Settings window should pop up. Make sure your “Object/Transient Cache” item is set to Disabled.

    This fixes the problems I am having while editing my themes.

    • Dalton

    • July 24, 2013 at 3:57 am

    @Full Circle Design: That seems to be correct – you need to disable the Object/Transient Cache fully to modify the fields, otherwise it takes changes a few minutes to show up in the admin.

    I didn’t know WP Engine was caching wp-admin, this seems like it would create more problems than it’s worth, in my opinion.

  • Thank you all for this thread! I was experiencing the same issue and disabling Object/Transient Cache fixed it. Whew. 🙂

    • mrwweb

    • August 9, 2013 at 7:27 am

    @admin, is there any chance that this can be resolved in future versions of ACF or is this something I should bother pleasantly request WP-Engine look into.

    Turning off caching is doable while in development, but I’d like to avoid it when the site is in production.

    • Dalton

    • August 9, 2013 at 11:57 pm

    I’d say that it’s worth posting a support ticket about it. If they get enough of them, they may do something about it.

    • Elliot

    • August 10, 2013 at 10:52 am

    Hi @mrwweb

    I’m not 100% sure if I can bypass this issue from within ACF.
    Is the issue striclty related to wp engine, or can the same issue be created with a plugin like w3cache?

    • Dalton

    • August 12, 2013 at 11:36 pm

    I’ve only been able to reproduce this in WP Engine, not on a local site with Super Cache enabled.

    I think the key is that the feature is called “Transient/Object Cache”. Elliot, do you use transients to store any temporary data when editing fields?

    • Elliot

    • August 13, 2013 at 1:58 pm

    Hi @Dalton

    No, transient is not used with ACF, however, ACF does use the simple wp_cache_set / wp_cache_get functions to cache the field groups. Perhaps this is where WP Engine is creating the transient…

  • Yep, same problem here. Fixed by disabling the Transient/Object Cache on WP Engine. Not ideal. I contacted them about it and will report back with any useful information.

  • awesome thread, really helped me out, has anyone heard back from WP Engine with an update on the issue? I’m about to open a ticket now just to keep them on their toes, dont see why admin content needs to be cached….

  • @williamotto, sorry I didn’t report back here. The gist of WP Engine’s reply to me was that Elliot (plugin author) is aware of the issue and they included some links to similar threads on this forum. Search for “wp engine”.

    My solution was to turn of WP Engine caching while developing. Not ideal.

    This is in no way a gripe from me re Elliot or ACF. The man is a gun and this plugin is incredible. Maximum respect.

    I’ve had all sorts of issues with WP Engine caching…

  • @ben Pearson thanks for the reply, im doing the same thing for now of turning off caching while developing, annoying but it does work.

    I completely agree that Elliot and ACF are two of the best things to happen to wordpress, makes my life so much easier !

    A bit disappointed in WP Engine over this, but hopefully something will be done….

    • Luis

    • November 27, 2013 at 4:09 am

    I’m having the same problem with Memcachier.

    For some reason, if you update a field, ACF is getting the cache of that field, instead of the updated field. If I flush the cache I can see the updated field, so the data is there.

    ACF should not retrieve the cache when the field has been updated. I don’t think this is a WP Engine problem, but a design problem.

    • jon_b

    • January 30, 2014 at 9:47 am

    i’m currently going through this process with wpengine right now. while it’s really strange that they’re aggressively caching wp-admin, there’s likely a reason why it makes sense for them and the workaround is just to disable it while you’re working on a site. what baffles me, however, is that they’re caching wp-admin for staging sites as well. yikes.

    i worked on a site last fall and made extensive use of acf and the flexible content add-on…didn’t experience these issues at all. i wonder what’s changed?

  • I notice that wp_cache_delete is never called to invalidate the item cached here:

    https://plugins.trac.wordpress.org/browser/advanced-custom-fields/tags/4.3.4/core/controllers/field_group.php#L63

    Could that be related?

  • I believe it is related. I was just having some issues in development where I had installed wp-redis to test out object caching. By installing the object-cache.php to wp-content, you are effectively using a new (better) form of caching for the wp_cache_* functions.

    I’m not sure why it’s not an issue with the default cache, but becomes a problem on WPEngine, wp-redis, possibly other memcached plugins… but that seems to be the case.

    I asked the wp-redis author about it here: https://wordpress.org/support/topic/unable-to-clear-transients

Viewing 23 posts - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.