Support

Account

Home Forums Backend Issues (wp-admin) TypeError: o is null on acf-input.min.js after update to 5.7.2

Solved

TypeError: o is null on acf-input.min.js after update to 5.7.2

    • ComsUp

    • August 6, 2018 at 5:54 pm

    Hi,
    we can’t use image field after the update, we see on the console the error “TypeError: o is null[Learn More] acf-input.min.js:1:5229” and we can’t do anything with image field.
    Do you know how to fix this? We use ACF PRO and it’s a backend issue.

    Thanks

    • ComsUp

    • August 6, 2018 at 6:11 pm

    I rolled back to version 5.6.10 and it works, it’s an issue due to your update.

    • basenic

    • August 6, 2018 at 7:17 pm

    Hi,
    i too have problems after the update to 5.7.2. I can’t drag and drop sections on a page and can’t add or delete them. In the developer-console the following message appears:

    acf-input.min.js?ver=5.7.2:1 Uncaught TypeError: Cannot read property 'collapsedLayouts-26' of null
        at Object.e.getPreference (acf-input.min.js?ver=5.7.2:1)
        at acf.Model.load (acf-pro-input.min.js?ver=5.7.2:1)
        at i.addCollapsed (acf-pro-input.min.js?ver=5.7.2:1)
        at initialize (acf-pro-input.min.js?ver=5.7.2:1)
        at i.t (acf-input.min.js?ver=5.7.2:1)
        at i.acf.Model (acf-input.min.js?ver=5.7.2:1)
        at i [as constructor] (acf-input.min.js?ver=5.7.2:1)
        at new i (acf-input.min.js?ver=5.7.2:1)
        at Object.acf.newField (acf-input.min.js?ver=5.7.2:1)
        at Object.acf.getField (acf-input.min.js?ver=5.7.2:1)

    @comsup How did you roll back? Do i just have to replace the files? Or did the new update also change the database-structure of the plugin?

    Best regards.

  • I have the same JS-error after updating to 5.7.2

    • Elliot

    • August 6, 2018 at 8:59 pm

    Hi guys

    Thanks for the email,
    Elliot here – ACF dev.

    Thanks for the bug report and sorry for the JS errors.
    We have quickly fixed the issue and re-uploaded the plugin files online.

    Can you please re-download the ACF PRO plugin files from your account, this should solve the problem.
    https://www.advancedcustomfields.com/my-account

    Tip: You can also trick ACF into re-updating itself by editing the main “acf.php” plugin file and changing the two references of “5.7.2” to “5.7.1”. This will allow WP to check for plugin updates and you can then re-update the plugin 🙂

    • basenic

    • August 6, 2018 at 10:20 pm

    Great support Elliot! Just tried the new version and it is working as intended!

    Thank you and best regards.

  • Just updated to newest version, then tried re-updating after reading this post. I’m still getting errors when try to use Page Link fields on the backend.

    acf-input.min.js?ver=5.7.2:formatted:4826 Uncaught TypeError: Cannot read property 'id' of undefined
        at HTMLInputElement.<anonymous> (acf-input.min.js?ver=5.7.2:formatted:4826)
        at HTMLInputElement.dispatch (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-resizable&ver=4.9.8:3)
        at HTMLInputElement.r.handle (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-resizable&ver=4.9.8:3)
        at Object.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-resizable&ver=4.9.8:3)
        at Object.a.event.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-resizable&ver=4.9.8:9)
        at HTMLInputElement.<anonymous> (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-resizable&ver=4.9.8:3)
        at Function.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-resizable&ver=4.9.8:2)
        at a.fn.init.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-resizable&ver=4.9.8:2)
        at a.fn.init.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-resizable&ver=4.9.8:3)
        at d.triggerSelect (select2.min.js?ver=3.4.1:21)
  • @cakeandeatitdesigns Did you update by downloading the plugin from the site, or in another way?

    acf-input.min.js?ver=5.7.2 will probably be cached in the browser so I recommend to empty the browser cache after the update.

    I use Composer for installing new versions, but I had to clear the Composer cache to remove the Composer cached wrong version.

  • We are having the same problem:

    TypeError: o is null

    Reuploading advanced-custom-fields-pro solved the error.

  • I am running ACF Pro 5.7.3 and getting the same problem (JS Type Error when trying to select from a dropdown list). I tried removing and then re-uploading the plugin. Are there any other fixes?

  • I’m not seeing any JS errors in the latest version of ACF. Try clearing your browser cache as mentioned above.

  • +1 Still receiving JS type error when trying to select from a dropdown list: “Uncaught TypeError: Cannot read property ‘id’ of undefined”. ACF Pro 5.7.5. Had to roll back to 5.6.10 in order to regain usability.

  • Strange I have the same problem with 5.7.10… Cannot click on a drop down list in the admin, got the “Cannot read property ‘id’ of undefined”
    Maybe a conflict with another plugin or with new jquery… I’m on WordPress 5.0.3

    Just to be more precise. It’s a Taxonomy subfield in a repeater. Empty is allowed. I return the term ID (not the object). Was working perfect before WordPress/Acf update…

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.