Support

Account

Home Forums Add-ons Repeater Field Two level repeater not saving in wp-admin

Solved

Two level repeater not saving in wp-admin

  • HI, I’m not sure if this was posted before.

    I’m trying to save a two level repeater field to a custom taxonomy named Vehicle Version, that means a “Group name” with a list of label=>value pairs. This is intented to save vehicle version attributes like for group name “Motor”: # of Cilinders => 8, Type of suspension => McPherson, etc.

    The fields saved before the last update was saved fine but now the new ones are blank. Please see the attached pic after update taxonomy, they are two blank fields which has been added after creating this taxonomy.

    This was working earlier but I suspect that the last update could break something.

    I’m using WP 3.8 with all updated ACF plugins.

    Thanks.

    Update: Removing all the group fields and adding all again is the only solution at the moment, there is not possible to add more later πŸ™

  • Hi @noisemedia

    Thanks for the question.
    You will find the same issue in this thread:
    http://support.advancedcustomfields.com/forums/topic/option-fields-not-saving-within-flexible-content/

    In short:
    The wp_options table has a character limit of 64 on the options_name column. This means that WP can’t save any data that exceeds this limit. Your nested repeater field is most likely causing the field_name to become too long.

    Please read the linked thread for some solutions.

    Thanks
    E

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Two level repeater not saving in wp-admin’ is closed to new replies.