Support

Account

Home Forums ACF PRO The update from 5.0.5 to 5.0.6 is not working – update not available

Solved

The update from 5.0.5 to 5.0.6 is not working – update not available

  • Hi. I’ve migrated a local developed site live. It uses acf pro 5.0.5 at the moment. wp_home and wp_siteurl are both the sites domain without any trailing slash. Set in the db as well as in the config.

    Locally i had issues updating acf via the update function, as already posted on here, when i used the following two statements in the wp-config.php:

    define('WP_HOME', 'http://'.$_SERVER["HTTP_HOST"].'/mylocalsite');
    define('WP_SITEURL', 'http://'.$_SERVER["HTTP_HOST"].'/mylocalsite'); 

    Now it shows only the regular domain. But when i go to the update the updater states:

    An error took place while updating advanced custom fields pro: update package not available

    (that is just a rough translation cuz i only have the german localization when i tried) other plugins worked to update on the server without a problem. so it couldnt be a general problem. i also ran the wordpress background update tester and it passed all tests without a problem. no idea what could gone wrong ( unfortunately i have no access to the php error log yet. :/

    and the real odd thing is. i’ve tried right now to update the local version of the site with

    define(‘WP_HOME’, ‘http://’.$_SERVER[“HTTP_HOST”].’/mylocalsite’);
    define(‘WP_SITEURL’, ‘http://’.$_SERVER[“HTTP_HOST”].’/mylocalsite’);

    in the wp-config.php, what hasn’t worked before – but now it works again. the it just isnt working on the live site. argl i am seriously confused now πŸ˜€ Any further informations i could provide to track that issue down? best regards ralf

  • a brief follow up note. i finally managed to enable php_error.log on the server. But when i retried to update the plugin no errors showed up. :/

  • Hi @rpk

    Thanks for the bug report. Are you able to update any other plugins on the live site?

  • hmmm it was possible to update custom post type ui to version 0.8.4 yesterday. On Safari the error was a bit different. Package not available hasn’t showed up. instead the update plugin took felt forever (also for cpt ui). I then clicked on the dashboard again. In the case of cpt ui the plugin was updated anyway in the case of acf never. no matter how long i let the updater work.

    the failing update differs from safari and chrome. safari on the right and chrome on the left.

    https://dl.dropboxusercontent.com/u/8578/chromeleft-safariright.png

    about the things i tried aside. I let the background update tester run. it passes all tests without a fail. i also tried to install a new plugin. that also works.

    i switched on debugging in wp-config but no errors or warnings show up. i tried to add also define( 'FS_METHOD', 'direct'); like a friend suggested but that also hasn’t any effect. i’ve checked the network pane in the chrome dev tools while updating but also no errors showed up. Then i remembered one thing. The site is hosted on 1&1. They don’t allow gzip compression so you have to use zlib. therefor a php.ini file has to be in every folder (also in plugins). They are placed as symlinks to the original in the root. the php.ini contains

    
    zlib.output_compression =1
    zlib.output_compression_level =9
    error_reporting = E_ALL | E_STRICT
    log_errors = On
    display_errors = Off
    error_log = /homepages/4/d54545454545/htdocs/php-errors.log
    

    (i’Ve altered the path of the error_log for demonstration purpose in public here πŸ˜‰ )

    so i’ve deleted every php.ini symlink in the acf folders too as well as the one inside the root of the plugins folder. but still the same effect – the update doesn’t work. Now i am a bit out of ideas how to debug things a bit further. :((( Is it maybe a permissions issue of acf files and folders???? cuz i’ve manually downloaded and replaced the present version (it’s 5.0.5x – you recommended updating manually to fix a few js issues a few days back). Best regards Ralf

  • A new update of one of my installed plugins came in. I left the php.ini symlinks on purpose inside the plugin directory and then updated. It worked without any problem. Afterwards i retried the ACF plugin and it failed again. So i could factor out the php.ini symlinks as the cause of the problem imho.

  • Hi @rpk

    Thanks for all the info. i haven’t used symlinks before so I can’t be of much help, but is it possible to setup your site without them?

  • hm as written in my second to last post i’ve remove the php.ini symlinks from the root plugins directory and all acf subdirectories and it hasn’t helped while without removing the symlinks in another plugin the update was still no problem at all. so i could foreclose the php.ini as the root of the problem. must be something else.

    maybe access rights issues? which are the default right necessary normally? or should i try manually install version 2.07? maybe since the last update was a direct update and download in between official version revisions it might be that there something went wrong?

  • and about the manual update. is it the correct procedure to deactivate the plugin replace the plugin folder and then reactivate the plugin again?

  • Hi @rpk

    You don’t need to deactivate. Just simply delete the advanced-cusomt-fields-pro folder and replace it will the new version (make sure the folder is called the same).

    Perhaps the issue was due to permissions on the folder? Maybe WP could not delete / replace it during the update?

  • hm yep something permission related i also suspected or something related to the 5.05 version which wasn’t the initial but one between 5.0.5 and 5.0.6. So that lead to the update issues. Cuz i remember i’ve downloaded the official 5.0.6 on my local install and after the update worked again toward 5.0.7. On my remote install which was unable to update i compared the permissions but nothing out of the line grabbed my attention. Anyway i’ve replaced 5.0.5 with 5.0.7 on my remote install. Am curious now if it will work again on the next official update. I will keep the issue/thread open and unsolved till the next official update and give you a feedback then if things are solved now or still persist. Thanks for now.

    p.s. and thanks for the hint that deactivation isn’t necessary. i am always overcautious in that regard afraid to break things. πŸ˜‰

  • @elliot i’ve replaced the folder and updated to version 5.0.7 on the site. Today the update to version 5.0.8 showed in the wordpress update dialogue. When i tried to update again the same error “update not available” :((( And there isn’t any php.ini or blocking htaccess possibility left. everything switched off. Is there a way to debug it further?

  • Having this problem too using a custom folder to plugins :(.

    define( ‘WP_PLUGIN_DIR’, dirname( __FILE__ ) . ‘/lib’ );
    define( ‘PLUGINDIR’, dirname( __FILE__ ) . ‘/lib’ );
    define( ‘WP_PLUGIN_URL’, ‘http://’ . $_SERVER[‘HTTP_HOST’] . ‘/lib’ );

  • Hi @andremacola

    Thanks for the code. I’ll try that out on my local site and test the update issue

  • Hi @andremacola

    I’ve just tested the custom dir folder with your above code, and the update worked perfectly!

    Perhaps it is permissions issues? or something blocking the connection to the ACF server?

  • Hi @elliot Condon tried today again to update from version 5.0.8 to version 5.0.9 on the remote installation which made problems with previous update and the problem still persists. πŸ™ i still get update package not available. Is there any other way how i might debug things to figure out the root of the issue? also tried to disable all htaccess security measures and leave only the wp related snippet in. nothing helped. :/

  • @elliot Condon uhhhhhh i think i’ve figured out the reason why the “update not available” error showed up. today i’ve updated the specific page with the issue i’ve built online. updated a few plugins and ran again into the problem. updated manually and then tried around a bit again. around other steps i’Ve performed i’ve checked the activation state of the serial number. and well the field was empty. i guess that was the issue. i’ve thought by backing up my local install ( where acf was properly activated ) the activation state would be properly conserved and ported to the live server. πŸ˜‰ well an a bit faulty assumption on my side ;))) damn. i’ll have to wait until the next acf update but i suppose that was the sole reason. just wanted to let you know on a follow up that that was probably the cause of the problem. πŸ˜‰ sorry for the troubles!

  • @rpk Wow, thks for the tip. I did everything to resolve this problem in two of my sites. For some reason the key activation field was empty in production. =)

  • For others who have this problem – when it happens for me, deactivating then reactivating the licence key seems to work, and I can then update the plugin.

    hope that helps someone,

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.