Support

Account

Home Forums Backend Issues (wp-admin) Textarea not saving data

Solving

Textarea not saving data

  • No matter what I type in a textarea the info is not being saved.

    I disabled all other plugins and the problem persists.

    Versions:
    ACF 5.2.7
    WP 4.22

    Any suggestions?

  • I’m not seeing any problem saving data in textareas. Going to need a bit more information.

    Is this just a textarea or is it nested in a repeater or flexible content field? Or is it a field that is conditional? Basically any more information you can give me about the textarea, field name, etc.

    Is there a large amount of data besides the textarea that’s being submitted? Is there a large number of fields? or does this happen with all textareas?

  • Hi John,

    It is a plain textarea inside a group.
    Here is a screenshot

    You might see some invalid fields showing, that is because I was running ACF Field Validation plugin but disabled in to try and diagnose this issue.

    More perplexing, after your response I created a new group with a single field being a text area and it worked. So I’m dumbfounded.

  • That is a pretty large field group, and I can’t see what all of the field types are due to the errors, are some of them repeaters or flexible content with nested fields?

    Running into trouble with the php setting max_input_vars can cause strange results.

    Try installing this plugin: https://wordpress.org/plugins/wp-max-submit-protect/

    It will tell you if there are more fields being submitted than is allowed. This is actually what I initially suspected.

  • Okay it’s solved. I have ‘org’ as part of the field name and it seems that might be reserved or something because as soon as I changed it things started working again.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.