Support

Account

Home Forums Bug Reports Text-Area fields are not saving on Update

Solved

Text-Area fields are not saving on Update

  • I am using a textarea field on a client’s products to add an optional disclaimer. This has been working fine on the live site for over a year.

    However, recently the textarea field has not been saving on update. I have discovered that the Custom Fields block in the CMS is now called Advanced Settings and is showing all the ACF fields (as the Custom Fields block used to) but if the “disclaimer” field is showing in this block then it overrides the ACF form in the sidebar. The workaround so far is to delete the field in the Advanced Settings block, update the textarea field in the ACF form in the sidebar and then click update. But this workaround is clumsy and I would prefer a permanent fix.

    Previously I had the Custom Fields block turned off in the ACF Field Group options but this is no longer working. I suspect the recent update to WordPress has changed something that ACF was previously using or replacing.

  • Additional: I am running version 3.5.2 of WP, and version 4.1.8.1 of ACF

    Also running on this site is WP Ecommerce with Gold Cart. The site theme and build is being used by close to 20 clients and sites from a single Franchise so this will be a major issue for my clients.

  • Hi @papabearnz

    It sounds like the textarea field has a name which is conflicting with another plugin or field. The other posted value is then overriding the textarea and causing ACF to save ” as the value.

    Can you check that on the edit page, there are no fields that use the same field_name?

    Also, can you better describe the issue with the sidebar / disclaimer?

    Thanks
    Elliot

  • I just had this same issue. No matter which ACF field I created, nothing got saved. I tried opening the default WordPress Custom Fields from Screen Options and those worked ok.

    I had pretty much just ACF, ACF repeater and WPML installed on a WP. I ended up clearing the whole database and recreating the few pages I had, which resolved the issue. If you like, I can send you the non-working db-dump.

    I have the same versions of wp and acf as PapaBearNZ.

  • I’m getting a similar problem.

    After the most recent ACF update today neither previously existing textarea (WYSIWYG) fields will update to the front end nor new textarea fields show up on on the front end for previously existing pages/post types. The fields do however update in the admin side. The changes simply do not propagate to the front end. However on any new pages/post types created the fields update as expected.

    Please let me know if my explanation isn’t clear. Thanks!!

    P.S. Your plugin seriously rocks! Best plugin around for WordPress by far. Really turned it into a legit CMS.

  • Issue is partially resolved. It seems only field data used in sidebar.php (in this instance) is not properly updating for any fields, both new or old. Perhaps this is a change in the general functionality of the plugin? Guess I need to do some more testing for possible conflicts and dig through the docs a bit more.

  • this is a wider problem. In my installation, with wp e-commerce, the custom fields save on first save (new post/product), but fail to update when i update an existing product..

  • I found out it has to do with the order of saving values. WP-commerce/getshopped overwrites the values that are set by ACF. I understand this was fixed before, is this a recurring bug?

  • Hi there,

    same problem here.
    Just in the process of creating a new field group and after saving once I cannot change anything (like changing a field type or the order of the fields). I can create new fields though.
    I already have a field group in production that works fine.
    This is a new field group for a new post type.
    I started twice from scratch but that didn’t help.
    I also checked the sql logs, there were no errors and I cannot find a problem there. It even appears that the changes get written to the database but not displayed. I am not sure how the process of updating a field group works but I found my changed entries.
    I am using the latest WordPress and the latest ACF.
    I am also willing to help to debug.
    I’ve got full control over the server/mysql, but cannot disable all plugins and start from blank since this is a production site.

    Kind regards,

    Peter

  • This is a ‘save order’ issue with WPecommerce (getshoppped, wp e-commerce, etc for anyone looking for those tags). Both ACF and WPEC user ‘save_post’ with a priority of 10.

    By changing WPEC save priority to an integer lower than 10 seems to have solved the issue – no more serializing the data as WPEC custom field and thus overwriting the ACF data.

    !IMPORTANT – THE FOLLOWING FIX WILL BE OVERWRITTEN WHEN YOU UPDATE WPEC!
    This fix is for WPEC version 3.8.10. Visit product-functions.php (\wp-content\plugins\wp-e-commerce\wpsc-admin\includes\product-functions.php) on or near line 221 is the following code:
    add_action( ‘save_post’, ‘wpsc_admin_submit_product’, 10, 2 );

    Simply change the save post priority from 10 to 1 and the issue should resolve.

    Remember, this is NOT an issue with ACF, this is a race/save conflict occurring between two augmentations of the POST that are trying to submit on top of each other.

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Text-Area fields are not saving on Update’ is closed to new replies.