Home Forums Bug Reports Strange sync bug


Strange sync bug

  • We work on a rather large project using a bitbucket git repo.

    To make it feasible we take daily DB-backups and have installed to import json to ACF.

    After the latest update we decided to try without the github plugin and it worked well enough for some small changes. Then today it wrecked the whole setup: Emptying a couple of field groups that contained maybe a few hundred fields, and mixing another between json and DB.

    I had to do a reset, import the latest DB and use the github plugin again to get it working.

    If someone else has the problem, that plugin has worked well for us. I hope ACF sync becomes as reliable, but for now I think we’ll treat it with some caution.

  • Yes, i’ve noticed that too, especially for repeater fields, it keeps adding duplicates whenever i sync 🙁

  • I’ve made this mistake a few times. If you check your acf-json directory into version control and make field edits locally, when you deploy to production the fields will show up correctly and all is good.

    However, if in the future you sync your local database with the db from production the ACF json fields will no longer exist in the database.

    This makes sense but isn’t immediately obvious when the local acf-json still shows the fields as appearing when you edit posts, but not when you edit the custom fields.

    I couldn’t get ACF’s default sync ( or the FreshFlesh acf-sync plugin to work with a manual json sync, but this plugin did seem to work, though I haven’t thoroughly checked to make sure all the data is intact.

  • Yeah I’ve noticed this too, along with an issue whereby values aren’t picked up at template level until the post is ‘updated’ which seems to refresh the post values.

    This seemed like a great feature to keep ACF fields in GIT and sync’ed between environments, but it’s caused more hassle than it’s worth at the moment!

  • Hi guys,

    Thank you for alerting us about this bug.

    I will now try to replicate this issue and forward the results to Elliot.

  • Was there ever any progress made with this? I’m developing a site at the moment and want to keep the fields sync’ed using the JSON backup, but don’t want to run in to problems if I use MigrateDB to push over DB changes.


  • Hi @mttd,

    I believe this issue is now fixed.

    I cannot reproduce this issue on the latest stable version of the PRO plugin, v

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Strange sync bug’ is closed to new replies.