Support

Account

Home Forums Backend Issues (wp-admin) strange "Error Field type does not exist"

Solving

strange "Error Field type does not exist"

  • Hi,
    After saving changes to Fields Group, I’m getting Error Field type does not exist for one field out of 4. Field label and field key are empty in ACF admin panel for that field. On post edit page the field looks fine – with label and data in it. After deleting that field and creating it from scratch I get same field with error and 2 more empty fileds under the “error” one both in acf panel and post edit. No idea what’s going on. Anyone any idea how to fix that?. Thanks

  • Hi @heyao

    Could you please tell me the ACF and WordPress version you are using? Also, could you please try to reproduce the issue on one of the WordPress’ stock themes (like Twenty Fifteen) with other plugins deactivated? If the issue disappears, then you can activate the theme and plugins one by one to see which one causes the issue.

    Hope this helps.

  • Hi James I came I use the following filter I get the same issue:

    add_filter('acf/load_field/name=hidden_post_id', 'make_hidden_post_id_readonly', 10, 1);
    function make_field_readonly($field) {
      // sets readonly attribute for field
      $field['readonly'] = 1;
      return $field;
    }

    the hidden_post_id disappears from the field group in the acf menu.

    I actually copied that filter script from John Huebner:
    https://support.advancedcustomfields.com/forums/topic/accept-only-unique-values/#post-45352

  • Hi @nigel-rodgers

    The field disappeared because there’s an error in your code, but you don’t have the debug mode enabled. So instead of showing the error message, WordPress was just showing nothing. This page should give you more idea about it: https://codex.wordpress.org/Debugging_in_WordPress.

    The issue you had was because you had a different function name between the filter and the function itself. The filter uses “make_hidden_post_id_readonly” while the function is “make_field_readonly”. Kindly change it so they have the same function name.

    I hope this helps 🙂

  • Thanks! Sucks being new to coding, But you guys make it worth it!

  • Hi,

    We are getting this error too. We just purchased the Pro version and updated our ACF plugin by following the V4 to V5 instructions.

    Our custom field -> field type -> Content -> Image is not recognized, and the “type” column says “Error Field type does not exist”.

    When I create a new field and click on the drop down menu for field type, I see under Content heading:
    Wysiwyg Editor
    oEmbed
    Gallery

    Image is no longer listed on that drop down menu.

    Thanks for any help you can provide!

  • hm….i think i solved the problem. I deleted the pro plugin, redownloaded it from the acf website, and reuploaded it.

    Somehow, I think not all the files uploaded the first time around. The plugin works now.

  • I know this is an old thread but just wanted to say thanks for all your replies – this thread helped me work out why my company’s downloads page (driven by WPDM and ACF) had stopped working.

    In the WP-Admin area, several Field Groups contained a “Field type does not exist” error in the ‘Type’ column. It took me a while to figure out that those broken field groups were using the ACF ‘repeater field’ type, which is driven by the separate ‘ACF Repeater’ plugin. The plugin had been accidentally deactivated on our setup and just needed reactivating.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.