Support

Account

Home Forums Backend Issues (wp-admin) 'source code' button on wysiwyg editor field

Solved

'source code' button on wysiwyg editor field

  • I like the wysiwyg editor field.. except for the horrible source code button. Its not very convenient to have to edit compressed html.

    On Tinymce’s own page there is an example of a their toolbar, and their ‘view source’ tab has properly formatted html. Can ACF show that sort of formatted code?

  • Are you talking about WP text view for a WISIWYG or an actual button on the toolbar that pops up a window with the html in it.

    The first is all WP and ACF does not alter that.

    The second, I believe, is probably from another plugin you’re using. ACF does not add it. I know for example that TinyMCE advanced adds this button. In that case you’d need to talk to that plugin’s developer.

    ~JH

  • Hi, I don’t think the tinymce editor is created by another plugin. I’m just using ACF’s own Wysiwyg Editor fields. I’ve attached two screenshots to illustrate the problem:
    source code button

    source code pop up

    Its hard to edit code with no formatting like that. I’d like the line breaks and indentation of the code.

  • Did some more digging and this is what I’ve found.

    This is ACF4, it has the code icon to edit the source, ACF5 uses the standard WP visual/text option.

    I thing, though I could be wrong, that for ACF4 the icon and the code editor itself are the native TinyMCE icon and editor.

    I know that bugs are still being fixed in ACF4, but I don’t think that improvements are being made at this point.

  • Hi @photocurio

    Thanks for the topic.

    I agree that the ACF4 code button is messy and is why in ACF5 (currently ACF PRO), the WYSIYWG field uses a native visual/text tab (just like WordPress)!

    ACF5 will be released shortly as a free plugin. Until then, good luck with your projects!

    Thanks
    E

  • Ah, how perfect is that? Thank you folks for this amazing plugin.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.