Home Forums Front-end Issues Show Add New Tag Plus-Symbol to all Users


Show Add New Tag Plus-Symbol to all Users

  • Hi ACF Team,

    I am running a listing website using ACF Pro. A form enables users to add new entries and that form also displays the taxonomy (tags) field. Adding new tags in that front-end form is enabled, and if I am logged in as an admin user there is a little plus-sign appearing on hover.

    However, that same plus sign isn’t shown once a user of any other role is using the same form. The following DIV is simply missing for such users:

    <div class="acf-actions -hover">

    How can I possibly make it work for anyone using the form, not just for admins?

    Thanks, Ralph

  • Adding terms to a taxonomy requires the WP manage_categories permission.

    Your choices are limited.

    You could edit roles and give everyone this permission, but that’s probably not a good choice.

    I might be possible to give this permission temporarily when viewing a specific page. I’m now 100% sure about this or how it can be done.

    And the last choice is to include a separate text field that is only shown when a user does not have the correct permission using the acf/prepare_field filter and then adding an acf/save_post filter that will add the term to WP and then set it as a post term.

  • hi John,

    Thank you very much. You wrote „ Adding terms to a taxonomy requires the WP manage_categories permission.“

    In the field settings I gave anyone the right by enabling „add new tags“ (the frontend form is only visible to user role „author“ anyway, so no misuse risk).
    Again: when accessing the form as admin, in accordance with the above setting, I do see a plus sign appear on hover that allows adding tags. But that same plus sign isn’t visible for „author“ role. To me, that doesn’t make sense, because the setting isn’t role specific (I thought).

    How and where can I add the permission you mentioned?

    Best, Ralph

  • The Author role does not have manage_categories by default.

    There are plugins that allow you to alter permissions like

  • Thank you very much John,
    This solved it for me.

    Thanks again for the helpful and fast support. Best, Ralph

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.