Support

Account

Home Forums General Issues Shortcodes Ultimate only works with default WYSIWYG

Solving

Shortcodes Ultimate only works with default WYSIWYG

  • Hi!

    I have a problem when using Shortcodes Ultimate. Please have a look at http://postimg.org/image/d1p82rp2x/ where I visualize my problem.

    Is there any solution to this? My hope was that the WP WYSIWYG addon was going to solve some of my problems.

  • Hi @bondra

    I don’t understand the problem. Can you please clearly articulate what is wrong with the attached screenshot?

    Thanks
    E

  • I’ll try to explain further.

    The first text editor seen is the native WP text editor, the second one is a texteditor used by a ACF field. Next to each editor there’s a “Insert shortcode” button (which is another plugin). The problem is, when I click this button to insert a shortcode to the second editor seen in the attached image it instead apply that code to the first text editor rather than to the second one.

    Are you following? 🙂

  • Hi @bondra

    Thanks.

    It is possible that the shortcode plugin is only made to insert into the main WYSIWYG editor. I would contact the shortcode developer and ask them if the plugin is compatible with ACF or any extra WYSIWYG editors on the page.

    Thanks
    E

  • I sent an email to the developer of Shortcode Ultimate plugin with the question. See if they got any answer to this.

  • I have the same problem. If this problem can’t be solved is there any shortcode preset good plugin that works with ACF?

    Thanks

  • The original issue seems to have been resolved for me.

    A new observation regarding compatibility for me now is that paragraph tags are wrapped around the shortcode when I hit a new line in ACF’s WYSIWYG editor. For example:
    <p>[su_row]</p><p>[su_column size="1/3"]</p>

    I’ve also tried manually removing the paragraph tags via the Source Code button in ACF’s WYSIWYG editor, but the paragraph tags remain.

    For the others experiencing this as well, I’m working around it by using Shift+Enter (line breaks) instead of Enter (paragraph).

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Shortcodes Ultimate only works with default WYSIWYG’ is closed to new replies.