Support

Account

Home Forums ACF PRO Screen options must be checked: bug or feature?

Solved

Screen options must be checked: bug or feature?

  • Since 5.1.9 (I think), ACF fields are not displaying unless ticked in “Screen Options.” Is this a bug or new feature?

    It feels like like a bug when fields are suddenly hidden in WP admin, and extra steps are required to get them to display the way they always have.

    Fingers are crossed that it’s a bug that will be wiped out in a blink.

    • Dalton

    • February 26, 2015 at 11:21 am

    This is definitely a bug! I’ve reported it to the ACF team, I’m still waiting to hear back.

  • I’m running into the same issue with my websites.

  • Hi there,
    I have got the same problem in the latest pro-version. And my categories meta box is gone and I allways have to activate it again via options.
    Cheers,
    Denis

  • Same issue here. Any idea on a future fix?

    EDIT: FYI, I’m on 5.2.0.

  • I also believe there is a bug with the latest PRO v5.2.0. Besides hiding its own meta boxes, it’s also hiding the meta boxes from other plugins. In my case, it was hiding the Events Organizer meta boxes(event details). I had to keep going to the “Screen Options” to show the events meta boxes again. I went back to v5.1.9.1 and fixed the problem. I hope that is fixed in the next release as I hate to keep using outdated plugins.

  • @harrison Good to know v5.1.9.1 fixed the issue for you. Where were you able to download that from?

  • You can download 5.1.9 (or indeed any previous version) by clicking “Account” (above) and logging in. In the “My Licences” section of the account page you can choose which version to download.

  • @jim Fitzsimons That appears to have fixed the issue I was having. Thanks a ton. Hopefully they rollout a fix soonish, but this works fine for now.

    EDIT: Nevermind. The issue is still there.

  • If it makes any difference, it appears to be that any ACF fields that are shared across multiple pages will remain shown if I visit those pages one after the other. As soon as I visit a page that doesn’t have that same ACF field as the previous and I head right back to the previous page, the field becomes hidden.

  • In case anyone needs a quick, dirty fix: I added the following CSS block to the acf-global.css file to force show all of the respective ACF fields in the editor (less than ideal, but a temp fix).

    .acf-postbox {
        display: block !important;
    }
    • comvis

    • March 11, 2015 at 6:59 am

    Hello,
    in my case i add custom style in Function.php
    Maybe quick way and undestructive method ?

    #categorydiv{ display: block !important;}

    That seems to solve problem for me

    • Elliot

    • March 11, 2015 at 1:58 pm

    Hi guys

    Thanks for the bug report. This issue should now be fixed in v5.2.1

    Please test and let me know if the problem is resolved.

    Thanks
    E

  • So far, so good – I’ll keep an eye on it!

    Troy

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.