Home Forums General Issues Saving Issue on Very Loaded Posts


Saving Issue on Very Loaded Posts

  • Hi,

    I have a field group that has many repeaters and flexible content. Users sometimes populate contents that are very loaded and we have seen that in some cases, when there are too many fields, WordPress doesn’t save all the fields in the post. Seems like there is record limit on ACF or WP but we couldn’t really figure out where this limit is. Do you have any thoughts?

    Many thanks in advance,

  • If there is a problem with the values being saved then it is probably

  • Hi John.

    Thanks very much for your comment! We have increased the limit max-vars over 3000 but despite this, we still encounter this problem. Can be any other reason of ACF’s not saving the pages which have a huge content?

    Many thanks,

  • Does the page time out? What does it do exactly?

  • Hi John,

    Actually, there is not any timeout problem on our ACF pages. The problem is that sometimes if we add too much content on a page and if we update or save that page, total or half of the page content gets lost.

    To overcome this problem, we have tried to apply your suggestions in your first comment. And we have changed the values of some input parameters. But at the end of our tests, we couldn’t find any rational and visible relation between the input length parameters and the page content loss.

    The “values/test results” relation has occurred in like the list below.

    -If the max_input_vars = 999999999999999999999999999 => no content loss
    -If the max_input_vars = 999999999999999999999999999 => content loss
    -If the max_input_vars = 1000 => content loss
    -If the max_input_vars = 9223372036854775807 => no content loss
    -If the max_input_vars = 999999999999999999999999999 => no content loss
    -If the max_input_vars = 1000 => no content loss
    -If the max_input_vars = 999999999999999999999999999 => no content loss
    -If the max_input_vars = 999999999999999999999999999 => no content loss
    -If the;
    max_input_vars = 1000
    suhosin.get.max_vars = 1000 = 1000
    suhosin.request.max_vars = 1000 => content loss
    -If the;
    max_input_vars = 999999999999999999999999999
    suhosin.get.max_vars = 999999999999999999999999999 = 999999999999999999999999999
    suhosin.request.max_vars = 999999999999999999999999999 => no content loss

    As you view, there is not a visible relation between the values of the parameters and their test results.

    Now we are stuck in the solving the content loss problem on ACF pages. We want to learn that; in which other conditions can page content loss occur?

  • to know it it’s related to max_input_vars install this plugin If there are too many inputs this plugin will pop up a warning telling you what you have it set to and how many you are attempting to submit.

  • Hi John,

    As I investigated the plugin that you suggested, I understood that this is not a solution for “max_input_vars” problem on ACF. This is just a pop-up warning for users. Actually, we don’t solve the problem with this plugin, just inform the user about the problem.

    Is there any other solution for ACF’s “max_input_vars” problem?

  • If there’s a problem with max_input_vars, this will tell you about it so that you can fix it. The only solution for max_input_vars issues it to alter the php setting. Doing this will be different depending on your hosting. For all I know, some hosing providers do not allow it to be changed.

    If the issue is not max_input_vars and you don’t get a warning from this plugin then you can stop looking into solutions for this problem and look for something else, although given what you’ve said I don’t really know what else it could be.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Saving Issue on Very Loaded Posts’ is closed to new replies.