Home Forums Bug Reports Required Validation Bug


Required Validation Bug

  • We love using ACF. We did find one issue, when we moved over to 4.1.6 the required validation keeps stating there is a field that still need to be filled in before the post can be added. Even though all the required field have been filled in. We tried to remove the required field in both place and only one will not accept the update. Was wondering if there was a work around for this. We have recently updated to hoping this would fix the issue but it did not. Also wanted to stat that this is for a Post Object field.


  • Hi @aaroun@tg

    Just to clarify, the issue is if you have a post object field which is marked as required, the post will not save, even if you have selected a post?

    Have you checked your console log for any JS errors?

  • Yes. It wont allow me to publish the post because it thinks there is a still a required field with no content. I tried to remove the required option in the field group but it would not change. I got the notice stating that the update was made but opened up the field options and it still had required as yes.

  • I keep getting this error in my log under the post when I try to publish and also in the field group when I try to change the required option.
    “Use of attributes’ specified attribute is deprecated. It always returns true.”

    Says it is in the wp-admin/load-scripts.php

  • Hi @aaroun@tg

    Potentially, you are experiencing a conflict between ACF and another plugin.

    Are you able to deactivate other plugins / themes to test?

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Required Validation Bug’ is closed to new replies.