Support

Account

Home Forums Bug Reports Repeater inside a repeater not saving value

Solving

Repeater inside a repeater not saving value

  • Big fan of the plugin, been using it since I first bought it and never looked back!

    Not sure if this is a bug introduced by the latest WordPress 3.9 update – I updated one of my client sites earlier tonight and since then, I can’t seem to save values in a nested repeater.

    Basically, I created a custom options page to be able to use some global variables. Inside that custom options page, I have a main repeater which has 4 text fields and a repeater with 3 text fields inside it.

    The text fields on the main repeater work as intended, and I seem to be able to enter and save values into the 3 text fields inside the nested repeater, after I clicked the “Save Options” button, the values I entered still remain inside the text fields on the nested repeater, but if I go to other pages and return to the options page, all the values (inside the nested repeater) disappear!

  • Hi,

    Thanks for this amazing plugin

    We are having a similar issue. We upgraded to 3.9 and to the current version of the plugin.

    We have a custom post type with 3 nested repeater fields with the flexible content (For creating tables). When we click update the page loads for a few minuted then goes to a 404, or sometimes back to the page with the data gone.

    I have tried to break it up to one table per page instead of all of them on one page, but we are running into the same issue.

    I have changed our execution time to 600 seconds, and has not fixed the issue.

    Thank you,
    Drive Digital

  • I’m also seeing this issue in WordPress 3.9.1 with ACF 4.3.8 and ACF Repeater 1.1.1

    Hoping for a fix soon!

  • Same problem…. awaiting solution

  • A similar problem was found about a week ago: http://support.advancedcustomfields.com/forums/topic/relationship-field-loses-post-type-after-save/

    I am seeing the problem occur with anything past a basic field like text, text area, or radio. I’m wondering the bug is with how it saves the fields?

    Using the repeaters with a project that is close to launch and now this bug is requiring us to rework sections as they were reliant on the repeater field.

  • I am having the exact same problem, I cannot use nested repeaters on an Options page. When I add content to the Options page, hit ‘Update, the page reloads, but the fields come up blank.

    When I try the same on a page or custom post they work perfectly.

    Any Ideas?

  • I’m having exactly the same issue.
    Currently developing a website in WP 4.3 using ACF 5.3.0.

    When having site options with a nested repeater, only some of the field values are saved when clicking on save.

    After having done some tests, i looks like the cause of this is a limitation of character for the field-name inside the nested repeaters.

    for my case:
    timeline_title (14chars did not save)
    timelinetitle (13chars saved)

    test:
    abcdefghijklm (13chars saved)
    abcdefghijklmo (14chars did not save)

    so a workaround until this gets fixed is to use a maximum of 13 characters for field-names.

    cheers,

    Tom

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.