Support

Account

Home Forums Backend Issues (wp-admin) Repeater field values disappearing

Solved

Repeater field values disappearing

    • pasnon

    • July 9, 2013 at 8:27 am

    I am using a repeater field to display 3 repeating fields: 2 text lines and one page link. First, the page link stopped saving the entry – it would go back to undefined after you saved the page. I deleted it and renamed it and it seems to work now. But now, another field (plain text field) just started doing the same thing. I have so much already entered into these fields i REALLY don’t want to delete and have to start all over again – it is around 70 fields x 6 different taxonomy pages I am using them on.

    Do you have any idea what might be causing this? I upgraded to the newest version but it is still happening.

  • Need moar info! Does it work properly in a different browser? What browser(s) are you using, and do any of them show errors in the debug / dev tools consoles? (tip: F12 to open tools, usually)

    Next step in troubleshooting might be to change your theme to one of the defaults (Twentyeleven, twentytwelve, etc) and see if the fields work properly then. If they’re still broken, disable all plugins (except for ACF of course) and test it again! Hopefully somewhere in there you can narrow down the source of the problem.

    • Elliot

    • July 9, 2013 at 10:14 am

    Hi @pasnon

    I wonder if this issue has only started since updating to v4.1.7

    A few other users are experiencing an issue similar to this and I will be publishing a fix soon

    • Elliot

    • July 9, 2013 at 10:33 am

    I’ve just pushed an update to github containing a fix for this cache issue.

    Can you please update to the latest nightly build and let me know how it goes?

    • pasnon

    • July 10, 2013 at 2:27 am

    @elliot thanks so much for looking into this.. I’m not sure when it started, but this is the first time it’s happened.
    Unfortunately the update still hasn’t fixed the issue.

    It makes me feel like something happened after an update, because half of the entries in there are just fine – and I can update and save the text in that field just fine, even add new ones above them. Those may have existed before the update. But editing any of the ones below line 11, it doesnt save the text in that field. 10 seems to be the cutoff point. I can add ABOVE #10, but then when it pushes 10 to 11, the text in 11’s field now becomes blank. Anything beyond 10, just for that field, is blank.

    Any ideas?? Thanks for your help.

    • Elliot

    • July 10, 2013 at 2:30 pm

    Hi @pasnon

    This sounds like your server is running out of memory during the save process and terminating the save function.

    Perhaps check with your server support that there have been any PHP memory errors on your site at the time you attempt to save

  • I have the same problem, if it is memory error why it is suppressed?

    In my case I cannot add any more than 23 repeater fields (ACF v4)

    Where can I find latest version from git?

    • pasnon

    • July 13, 2013 at 1:45 am

    I’m sorry, but I didn’t get any error messages to tell me it was a memory issue. I thought it would be something simple, stopping at a flat number like 10, but apparently it was arbitrary if @evalds.urtans is experiencing the same thing at 23.

    I ended up deleting the field and starting over completely – this one works fine, I am able to add as many as I want. I’m just worried it’s going to happen again, I’ll let you know if anything else weird starts happening. 🙂

    Thanks!
    Jamie

  • If I delete whole post and start over again I can add more, but it brakes all of the time for me – I have at least 4 damaged posts like this.

    Where can I find latest version from git?

    elliot, maybe you have idea where should I search in code to fix or diagnose it? I am using multiple nested repeaters together with some flexible field types

    • pasnon

    • July 13, 2013 at 2:58 am

    this is the same for me – the second time the repeater’s broken on this site.

    • Elliot

    • July 14, 2013 at 4:41 pm

    Hi @pasnon, @evalds.urtans

    I wonder if it is timing out because you are also saving all that data to the post’s revision.

    Can you disable revisions for that post type?

  • @elliot it did not help &it saves in less than 1sec. How can I send you access to this WP privately? I am able to save/change anything below certain numbers of items

    • Elliot

    • July 14, 2013 at 5:45 pm

    Hi @evalds.urtans

    You can add me as a user to the site and reply with the login details here. Just mark the reply as ‘private’

    Cheers
    Elliot

  • This reply has been marked as private.
  • Can you give me some hints where the problem might be?

    • Elliot

    • July 17, 2013 at 12:38 pm

    Hi @evalds.urtans

    I believe the issue is definitely that you are hitting a server limit of the number of allowed posted variables.

    This is a PHP value that you can increase (please contact server host).

    I would first check the server logs for any errors

  • What is the name of this php flag? Thanks

  • Thank you very much, after changing htaccess like this:

    php_value max_input_nesting_level 128
    php_value max_input_time 300
    php_value max_input_vars 3000
    php_value max_execution_time 300
    php_value post_max_size 32M

    it worked. It might be overkill, but I was not sure which one of these were at fault

    • pasnon

    • July 18, 2013 at 12:09 am

    This is great, it fixed my issue as well!
    Thanks so much for looking into this.

  • I know this issue is marked as solved but I seem to be having a similar (maybe the same) problem and I thought I’d start here.

    I have a page (used as home/front-page) with 2 repeater fields. Everything seemed to be working OK until I entered data into the fields of the second repeater. Now the values of the fields appear to be permanently saved to the database and I’m unable to add or edit any values at all. I can only update them directly in the database through phpMyAdmin (or the like). I’ve tried to implement the php.ini/php_value values and that didn’t solve the issue. The only one I wasn’t sure how to get working (and confirm it) was the max_input_vars.

    FYI: Currently the site is running on MAMP

    Any help is greatly appreciated and thanks in advance. Viva la ACF!

    • madsynn

    • August 2, 2013 at 9:27 am

    I am also having this issue how can i import my field group and have all the fields in it not just 23, i need my repeater fields to also import?

    • AlecsK

    • August 2, 2013 at 10:11 pm

    Have the same problem. Or nearly the same.. don’t know. Nightly build of ACF, WordPress .6 and I can’t sometimes update some fields. But it’s very strange. I configured an option site with many repeaters, repeaters IN repeaters and some normal input fields.

    So.. first I had problems with some fields (in the middle of all content). After some variable-updates (no shopware installed..) it works fine. But now one of the last input fields doesn’t update. I updated the variable-names, deleted the field … nothing works.
    Now I added a test-field and this one works! … it’s so strange.

    greets

  • If something strange happen, like this one, always check httpd errors first.
    I got a similar problem in acf field creation area.

    [error] [client 127.0.0.1] PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0, referer: http://local.dev/wp-admin/post.php?post=728&action=edit

    Yep, error tells you what to do. Just increase max_input_vars value in your php.ini. I see my local installation dont even have this value but you can just add it to php.ini and restart server. It will work 🙂

    Some discussion on this: http://stackoverflow.com/questions/10303714/php-max-input-vars

    • mores

    • October 13, 2014 at 9:01 pm

    I would like to chime in.
    After YEARS of having this issue I finally found this thread.

    For me it was 39 fields, meaning ACF didn’t count past 38.
    The only way I could fix this was by manually changing values in the custom fields column.

    By adding the line
    php_value max_input_vars 3000
    to my .htaccess I was able to correct this.

    Thank you for sharing this.

  • Also try:

    [suhosin]
    suhosin.request.max_vars = 1000
    suhosin.post.max_vars = 1000

Viewing 25 posts - 1 through 25 (of 29 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.