Support

Account

Home Forums Add-ons Repeater Field Repeater Add button not showing

Solving

Repeater Add button not showing

  • In the past, when I had a pro account, I could simply register a custom field and when I go to the specific page, I would be able to add multiple custom fields of that blueprint that I had set up.

    Now I cannot see the “Add” button anymore. It simply forces me to only have 1.

    Curious why this is the case and how can I solve this?

    Wordpress version: 5.3.2 (I have also tried 5.3 and 4.8.9, none of which worked)

    ACF Pro version: 5.8.7 (I was previously on 5.4.? I forget exactly which one)

  • This is still a problem for me. I’ve tried disabling all plugins but that didn’t work. I tried a fresh install of WordPress 5.3 and ACF 5.8.7, and this doesn’t work as well.

    If I try to download acf through plugins, then the “updates” menu where I would normally put in the key doesn’t show up. If I try to download the actual zip folder and then put the extracted content into my plugins folder (to forcefully ensure that ACF pro is available), I get to put in my activation key, but it still doesn’t work (in that the repeater “add” button on the particular page that houses the ACF isn’t actually available still).

    No matter what i do (I also tried to convert this into classic editor for wordpress), i haven’t been able to get the “add row” button to appear so that I can make use of the repeater function.

  • I have not seen any issues with ACF and the repeater add row button not appearing. In most cases this could be caused by a JavaScript error. Are you seeing any errors in console?

  • @hube2 The only error I get in the admin page when I’m on the page edit mode (it seems like a console warning and not an error actually):

    
    [DOM] Found 2 elements with non-unique id #_wpnonce: (More info: http post.php?post=55&action=edit:1 s://goo.gl/9p2vkg)
    <input type="hidden" id="_wpnonce" name="_wpnonce" value="0194ea0431">
    <input type="hidden" id="_wpnone" name="_wpnonce" value="ac8d4cf2e1">
    

    I attached a picture to show what I mean. In the past I used to have an add row button. Now I don’t (even in the actual custom field creation, I used to have fields that allowed me to choose what the button should be called e.g. I could call it “Add Box” or “Add Row” etc. Those fields themselves are now gone as well).

  • You’re using gutenberg and blocks, at least that’s what it looks like. I really cannot help you with this except point you to the documentation https://www.advancedcustomfields.com/resources/blocks/ and say that more than likely it’s an issue related to gutenberg.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.