Home Forums General Issues Relationship Field search not working


Relationship Field search not working

  • Seems like something happened in the last update. ACF relationship field search in the backend stopped working. No matter what I try, I can’t select new posts. I tried recreating the field and also tried changing the post type but it isn’t working.

    Here’s a screenshot of what I see:

    Please help!

  • I’ve tested this and I’m not seeing an issue.

    You need to start by deactivating other plugins and maybe changing themes to see if you can narrow down where the conflict is.

  • Similar conflict with using Page Links as well, where the select styling disappears and cannot be seen onscreen.

    Found the conflict is with Toolset Types. This is a widely used plugin, and suspect it’s due to their “front-end display” feature.

    Hope this helps someone else looking, and also hope for a fix.

  • There have been reported conflicts with types when it comes to select2 fields. Something about different versions. Thanks @jkuzma for the link here.

  • This happened to me on a very high traffic website and I didn’t have the option to troubleshoot things by disabling plugins.

    I deleted the relationship field, recreated it with the same name and the search started working again.

    P.S. I use a plugin called “Custom Post Types UI” and I think the relationship field search broke after I created a new custom post type.

  • I was having a similar problem, but with a new relationship field I created in php. I was also using Custom Post Type UI and found that if I went and re-saved the custom post type in Custom Post Type UI, the field started showing the posts.

    Hope this helps someone. Or me again when I search for this issue in another year hahahaha.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Relationship Field search not working’ is closed to new replies.