Support

Account

Home Forums Backend Issues (wp-admin) Publication/update issue with WP 5.0

Solved

Publication/update issue with WP 5.0

  • Since the upgrade to WP 5.0, for one of the site I developed, when ACF is active on a page, the “update/publish” button has no effect. I can see the POST /wp-admin/admin-ajax.php with 200 OK, but nothing happens.

    What I did to isolate the problem:
    – if I’m using a page template which is not using ACF -> publish/update works
    – I installed “health check” and the publish/update works until I activate ACF
    – I can’t see any javascript error in the console while clicking on publish/update page

    Any one got the same issue ? Any idea how to debug this ?

    Thank you.

    • EyesX

    • December 11, 2018 at 6:34 pm

    Got the same kind of problem since the 5.7.8 update. I do get a js error, but don’t know if it has to do with this issue.

    An invalid form control with name='' is not focusable

  • I do not see this error. But the issue could be related to ACF 5.7.8 update and not WP 5.0.

    According to the Changelog:
    https://www.advancedcustomfields.com/blog/acf-5-7-8-release/

    * Fix – Fixed all metaboxes appearing when editing a post in WP 5.0.

    Wondering if this could be related. As soon as I’ve got time I will try to reproduce the issue between 5.7.7 and 5.7.8.

  • Hi everybody.
    I have exactly the same problem. I have done several tests and have noticed that the problem arises using the Repeter field. In my case I have three subfiled: 1 datapicker, 2 select, 3 free text

  • Hi!
    Same problem with this version of ACF but with WordPress 4.9.8.
    I have downgraded to the previous version of ACF and it works correctly.

  • So, this is definitely an issue with ACF 5.7.8. I will not perform update on other installations.

    I will post an issue on the github of ACF. In general, do you know if they react quickly ?

    For the downgrade, I suppose this is only possible if there was no change in the database structure. And to do so, you simply replace the files in wp-content/plugins/advanced-custom-fields-pro ?

    Thank you.

    • ed206

    • December 12, 2018 at 11:44 pm

    Hi everyone,

    I also can confirm, this bug is present on my installation.

    An invalid form control with name='' is not focusable

    Occurs when trying to save with acf.

    • ed206

    • December 12, 2018 at 11:46 pm

    ACF uses the standard wordpress database schema, I think they do not touch database when updating. I downgraded by rollback my git repository to a previous state.

  • I’m also having this issue, but only when I have “Classic Editor” installed.

    • locomo

    • December 13, 2018 at 6:53 am

    I can also confirm this .. when I role back to ACF 5.7.7 the problem goes away

    An invalid form control with name='' is not focusable

    Wordpress 5
    Classic Editor installed

  • ACF support has been contacted, they also advised me to rollback to version 5.7.7 which I did and it worked around the problem.

  • I can also confirm this .. when I role back to ACF 5.7.7 the problem goes away

    An invalid form control with name='' is not focusable

    Wordpress 5
    Classic Editor installed

    Out of curiosity, where are you seeing this error?

  • Some reported to see this error in the javascript console. Personally I didn’t.

    • locomo

    • December 13, 2018 at 7:12 am

    yes javascript console

  • Same problem. This is my setup

    WP 5
    NO Classic Editor installed
    ACF PRO 5.7.8
    Custom post type WITH ACF PRO repeater field box
    the problem occurs only in post types where there is the repeater field
    if I downgrade to ACF PRO 5.7.7 everything works normally

  • Can someone change the status of this thread, downgrading to 5.7.7 is not a solution.

    I have the same issue with the same JS console error message. Downgrading does allow our client to update the page again but still is not a solution.

    • gaialabs

    • December 13, 2018 at 11:10 pm

    Well, we can discuss and argue that for hours. I marked this topic as solved as this is a workaround which works. So, if someone comes here, he can downgrade to 5.7.7 and he will be able to edit his posts again. And there is now drawback as the changelog between 5.7.7 and 5.7.8 doesn’t show lots of changes. So, you can perfectly live with version 5.7.7 and wait a few days for the version 5.7.9 to arrive, with the bugfix.

    • meandhim

    • December 13, 2018 at 11:20 pm

    Good point, sure thing.

    • meandhim

    • December 13, 2018 at 11:35 pm

    For everyone who is having the issue, please could you check to see if you have a Required field within the repeater?

    For me I had a required field in the repeater, making this not required resolved the issue.

  • Yes I checked and that’s exactly how it is: if the repeater does not have “required” the update button also works with the 5.7.8.

    you found the bug 🙂

  • Yes, even in my case the bug is in the pages where repeater fields with required subfields are active.

  • yes but only repeater field with required subfields

    • ed206

    • December 14, 2018 at 1:47 am

    I Agree,

    Downgrading is not a solution!

  • Happy to downgrade to fix this, but I’m stymied there too. I have WP Rollback installed, but it doesn’t give me the rollback option for ACF Pro. Just about all my other plugins, yup, but not this one. WP Rollback is recommended in the ACF FAQ, but it’s not working for me. Is there another plugin or another way to do it?

    WP 4.9.8
    ACF Proo 5.7.8

  • Of course it is not a definitive solution. It’s a workaround. But you noticed that this forum has only the possibility to define an answer as a solution.

    For someone who would read this thread, he could then find that, at this stage, downgrading is the only solution to solve the problem.

    The definitive solution will be to update with the next version, fixed.

Viewing 25 posts - 1 through 25 (of 28 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.