Support

Account

Home Forums ACF PRO Problems with "Hide on screen" and position

Solved

Problems with "Hide on screen" and position

  • After update 5.0.1, the Content Editor will no longer be hidden even if that option is selected.

    I have attached the .json file exported from the field group.

    For some field groups, included the attached one, choosing to position it high (after title) does also not work.

    Running version 5.0.4 now. Still doesn’t work.

  • I am having the same issue – any item selected or unselected in the “Hide On Screen” section is being ignored completely.

  • This problem reaches even further. Might have something to do with the new json format.

    I have a field group that I had previously set to display on the sidebar in the edit page. However, I now wanted to move it to below the content. It appears to save that, however, on the edit page, it still shows in the sidebar.

    None of the field group settings seems to be updated anymore….

  • I’m having the same issue – in the non-pro version.

  • The problem is still present in version 5.0.6. It’s really annoying.

    Any official response on this? 🙂

  • Hi guys.

    Thanks for the bug report. I’ve just experienced the issue, but then it resolved itself.

    I believe the issue is due to the local JSON feature causing an issue with the field group’s position being read correctly.

    Is it possible that any of you are using custom load/save paths for the local json feature?

  • Custom load/save paths? Not that I’m aware of at least. I only made the acf-json folder in the theme folder like the instructions told me to do.

  • No custom load/save paths for me – haven’t touched anything to do with json

  • Thanks guys.

    If you have a acf-json folder in your theme, can you please delete all files from it and re-load your edit page

  • I don’t have an acf-json folder in my theme. I ended up going another route to get the website done, but definitely want to keep ACF as my primary tool moving forward. So I’m very interested in seeing how this resolves itself.

  • @elliot Condon I tried what you proposed and it didn’t work. The Content Editor is still showing up.

  • Hi guys

    The only other thing I can think of is perhaps the field group which contains the ‘hide on screen’ settings is not the first field group to appear on the page. Is it possible that another field group is being loaded beforehand?

    Each field group contains a menu order setting to modify the order

  • Yes, that was it! 🙂

    I have a custom fields box in the sidebar that appears for all post categories. I set the Order No. to 5 and the problem is now solved.

    I do think however you should make it so that hiding takes priority over not hiding, for the options.

  • I came across this bug recently. Very awkward, since in my case a field group in the sidebar was preventing the_content from being hidden. Is this issue being resolved any time soon? I would suspect that the contents of the hide_on_screen array would be merged into a single array before the CSS is generated (includes/form/form-post.php lines 208-215, ACF Pro).

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.