Support

Account

Home Forums ACF PRO Problems with field type repeater

Solving

Problems with field type repeater

  • I am having a series of problems using custom fields with type repeater.

    With one field when I try to delete a row it seems deleted but after clicking “update” and seeing “Options Updated.” the row is still there.

    It happens a similar thing when I tried to update a field of type date contained in another repeater, it seems fine but after the page refresh, the date disappears.

    I am using Version 5.8.9 of ACF PRO and the latest version of WordPress.

  • Are the names of the two repeater fields the same or different?

  • We are experiencing the same issue where when we try to save a new repeater, all the field disappear on the first save, then we have to do it again for them to show.

    The in our option page, the repeater data are not saving, it looks like there is something going on with the latest version of the plugin. I am also using Version 5.8.9 of ACF PRO and the latest version of WordPress.

    Any ideas ?

    Thanks,

  • Hey Guys,

    My bad, the issue was caused by a function that rewrite the slugs on the fly, All good on my side now, sorry for the noise created 🙂

    Thanks,

  • Hey John,

    Thanks for the reply. Different names, they are two different field groups.

  • @luca_lbh the symptoms in your OP indicate to me that you have duplicated field names. This is the only thing that I know of that can cause updating one field to affect another field. It does not matter if they are in different field groups. All fields on the same post editor must have unique names.

  • They have definitely different names.

    What I really don’t understand it’s I do my changes, I click “update”, I see “Options Updated” but on refresh, the changes are reverted.

  • Here you can see a screengrab of the problem https://youtu.be/ZFmMQC4Admg

  • I think I found the problem, is there a sort of limit for the number of custom fields supported by each section?
    I just noticed that clicking update is passing all the fields contained in options, I removed some of the ones I added previously and it seems it’s working again.

  • There can be a limit but it is not imposed by ACF, it has to do with the PHP setting max_input_vars

  • I increased the max_input_vars value and it solved the problem.
    If this kind of problem occurs shouldn’t the plugin raise an error? I wasted so much time trying to debug this issue.

  • There is a plugin for that, hasn’t been updated in a while, but it really does not need to be updated and it works fine https://wordpress.org/plugins/wp-max-submit-protect/

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.