Support

Account

Home Forums Gutenberg Preview not updating

Solved

Preview not updating

  • Hi All,

    I have come across something weird that i’m hoping someone else has come across too (and is just something silly i’m missing!)

    If i have my block in Preview mode, and edit the content from the side bar, it all live updates nicely and as expected.

    However, if i add the content in Edit mode and then switch the block back to Preview mode to see what it looks like… the content doesn’t change.

    I was initially using a render template when registering my block, and switched to using a render callback instead (trying to rule out things really!) I also double checked it was happening to all fields in the block, no matter their location or type (as at first the problem seemed to be with wysiwyg fields inside accordion sections, but as it turns out, it literally doesn’t matter where or what type they are!)

    Anyone else having the same issue? Or am i missing something super obvious?! :^)

  • I’m only typing this in hopes it helps you narrow down your issue. I’m using render callbacks (to a function and not a php template file). I have none of the issues you describe. I have not tried a render template at all, so I can’t comment there.

    I can edit in preview mode or edit mode (I default to preview mode) and both will reflect the changes in preview mode either immediately (in preview mode) or when I swap to preview mode from edit mode.

    So far I’m only using text fields, paragraph fields, and checkboxes.

  • Hi timmy28x,

    Thanks for that! Every bit of input helps :^)

    Ok so, i tried a few more things. I tried doing the callback as a function rather than a php template, which made no difference! BUT then i thought, i wonder if you were using a previous beta as…i kind of got the impression you had a bit of experience with this!

    So i tried swapping over to Beta 3 and it works! Content is updating as i’d expect. Which leads me to believe (after literally commenting out all of my code and checking function by function to see if anything was breaking stuff!) that this is an odd issue with Beta 4!

    Can you confirm which version you’re using?

  • I’m using and have only used Beta 4… Have you submitted details of this as a support ticket? I’ve read that the developers don’t read these forums. I’ve submitted a ticket before and had a timely response. Best of luck!

  • Ah ok well that’s good to know!

    I’ve not, no but i will do that right now. Thanks!

  • Just a quick one to say, the latest beta update 4.1 fixed this issue! :^)

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.