Home Forums General Issues post type vs post object


post type vs post object

  • Hi! Sorry this might be a little noobish but I am having problems when trying to include a post object as a field for a particular group. My problem is that one of my custom post types is not showing up as an option.

    Trying to troubleshoot this issue I included in the get_post_types function:

    So when I try to create a new custom fields group I get the following array in the Location meta box:

    Array ( [post] => post [page] => page [attachment] => attachment [revision] => revision [nav_menu_item] => nav_menu_item [acf] => acf [videos] => videos [networks] => networks )

    Over the new field post type multi-select box I get the following array:

    Array ( [all] => All [post] => post [page] => page [attachment] => attachment [revision] => revision [nav_menu_item] => nav_menu_item [acf] => acf [networks] => networks )

    My Issue is that I need to include the custom post type “videos” as a post object to a different custom post type “networks” and cannot get it to show up when choosing a new post object. Is there something I’m missing here?

  • Never mind, just solved my own problem

    after troubleshooting a little more I figured out that I was registering the custom post type using a plugin boilerplate that, in order to reduce its footprint in the admin panel, only calls these plugin functions with no AJAX, which is something that the custom fields use when a user chooses the field type and loads the options via ajax.

    Such a pain but I’m glad I solved this.

    I changed:

    if( is_admin() && ( ! defined( 'DOING_AJAX' ) || ! DOING_AJAX )


    if ( is_admin() )

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘post type vs post object’ is closed to new replies.