Home Forums General Issues Post Objects stop working on 4.3.3


Post Objects stop working on 4.3.3

  • Hi!

    I just upgraded to the latest version (4.3.3) and the “Relational – Post Object” has stopped working.

    Any idea?

  • It works for Media and Post, but not for Page type.

    WordPress 3.8
    ACF 4.3.3

  • I’m trying to display Custom Post Type…

    I’m doing something wrong?

            'public' => true,
            'hierarchical' => true,
            'has_archive' => true,
            'rewrite' => array( 'with_front' => false ),
            'supports' => array(
            'can_export' => true,
            'taxonomies' => array(
  • Hi guys

    Sorry for this bug, it was caused by a change to the WP_Query args in the post_object field which is also used by the page_link field.

    In particular, the change was on lines 93 and 440 of the post_object.pgp file.
    You can manually change:
    'post_status' => 'any',
    'post_status' => array('publish', 'private', 'draft', 'inherit', 'future'),

    I have tracked down and fixed the issue. You can find the latest code on github, or wait for the next version to be released (soon).


  • Thanks Elliot,

    This solved my prob.


  • This worked for me, as well. Thanks for the quick fix!

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Post Objects stop working on 4.3.3’ is closed to new replies.